summaryrefslogtreecommitdiff
path: root/dev-python/pytest-timeout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-05-06 12:56:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-05-06 12:56:33 +0100
commit2b9bf8ddf02fa6c068d582794340e48fad5e55be (patch)
tree94e5e799096d433aec23d95d7f639067bbf741cc /dev-python/pytest-timeout
parent9a0e466823bee57eb01cc2c6cd2f3d89d8849c55 (diff)
gentoo auto-resync : 06:05:2025 - 12:56:33HEADmaster
Diffstat (limited to 'dev-python/pytest-timeout')
-rw-r--r--dev-python/pytest-timeout/Manifest2
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-2.4.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pytest-timeout/Manifest b/dev-python/pytest-timeout/Manifest
index 0603825a097d..f2383271c641 100644
--- a/dev-python/pytest-timeout/Manifest
+++ b/dev-python/pytest-timeout/Manifest
@@ -1,3 +1,5 @@
DIST pytest-timeout-2.3.1.tar.gz 17697 BLAKE2B 5f0ffa2fdda59ef28a92bfd5742891f63c1fa400db4ef89077fa13d917932d83e76d543c4c326a27df582a025122d8a75f1f7adf0daebbecc42273d4323ff93a SHA512 f200d625d11f76173521f4e2e4e09d57f6613d9b1420c57893b454ec496d5f11b32390b95eb995b403d15f8563b742a58fa0e0cbad42246b4049787a389ad83e
+DIST pytest_timeout-2.4.0.tar.gz 17973 BLAKE2B 97408cf5c9b49d809ef7a5d057afd22dfd856b64043879fa8e7d9f3996f76f5554bfed62bc8f40f4e5f28f058067b29b582953bf977fd1f6de95dfc7184ce41c SHA512 ca37754c20517024cb88e88e9c4d8497ff5c235d1bae4bc082d21b5807b43aac8294757900f9bc29e3e34a4b8c671136468793f47baadebf086f924b59b0bd0c
EBUILD pytest-timeout-2.3.1.ebuild 1165 BLAKE2B 3c5f1e88acee58ada888ec3138d80c1b5a2eb7924b9bfed11d1dcd992728c6e0849ddee1c7c85e4c8953f1f0e8350083ea3f10e6b52aa31c529813ffba6e986d SHA512 0636ceab2188bd0ddbc33a99472faa106587ff00c4b9f96912d606d84e0acaf63ce5c90e57934f97d64a0d204ae7ec2eac27cc7e97a005cc525b6d0f8335b01e
+EBUILD pytest-timeout-2.4.0.ebuild 1147 BLAKE2B 89812449bf2cc47a2520114314081cbc1bd4406e0e84e05815c6895d65b63a1b24f60ce9cddf1de39a39628729c295424e40888dc149f87490957595a431dd70 SHA512 ff61f067a6404f34ba8f8fb718c9c521e42df9f383840c80f3c9857a5be3b6866267d8733bd96d8222c50e5c93f62fdd912e49e3b24b904175cb782fff8901d7
MISC metadata.xml 420 BLAKE2B ff56de441243acbf2c7332acf224c8f64427378a8cd5f56c040eca1bcaae467459d8ae09409a963d0053a95035a4e7cfcda067d5be78bcd24ba222b2ce56d6f4 SHA512 c6b4ebdd5bd59452d0952e50526ca9b7cb5b88b12d989947a4775d60cdc9315d594ca7c37cb17c0cd4b2708d08db625f678fd577ac9031e0b0e6dbb364a6ad3a
diff --git a/dev-python/pytest-timeout/pytest-timeout-2.4.0.ebuild b/dev-python/pytest-timeout/pytest-timeout-2.4.0.ebuild
new file mode 100644
index 000000000000..f3649cb4aafc
--- /dev/null
+++ b/dev-python/pytest-timeout/pytest-timeout-2.4.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..13} python3_13t pypy3_11 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin to abort hanging tests"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-timeout/
+ https://pypi.org/project/pytest-timeout/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# do not rdepend on pytest, it won't be used without it anyway
+# pytest-cov used to test compatibility
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ !hppa? (
+ $(python_gen_cond_dep '
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ ' python3_{11..13} 'pypy3*')
+ )
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_timeout
+
+ if has_version "dev-python/pytest-cov[${PYTHON_USEDEP}]"; then
+ PYTEST_PLUGINS+=,pytest_cov.plugin
+ else
+ EPYTEST_DESELECT+=(
+ test_pytest_timeout.py::test_cov
+ )
+ fi
+
+ epytest
+}