summaryrefslogtreecommitdiff
path: root/dev-python/pytest-timeout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-10 00:01:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-10 00:01:14 +0100
commit17e5f1ea4a2e1c5664f96480ca46348d008e8711 (patch)
tree7166d1b58a582290a4ad23ff5882cca911b8035c /dev-python/pytest-timeout
parenta0ce545d52f231499bf9f3644493113d8af58ec9 (diff)
gentoo auto-resync : 10:05:2024 - 00:01:13
Diffstat (limited to 'dev-python/pytest-timeout')
-rw-r--r--dev-python/pytest-timeout/Manifest2
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-2.3.1.ebuild8
2 files changed, 6 insertions, 4 deletions
diff --git a/dev-python/pytest-timeout/Manifest b/dev-python/pytest-timeout/Manifest
index 5d6eaed1a206..df78ff330e62 100644
--- a/dev-python/pytest-timeout/Manifest
+++ b/dev-python/pytest-timeout/Manifest
@@ -1,3 +1,3 @@
DIST pytest-timeout-2.3.1.tar.gz 17697 BLAKE2B 5f0ffa2fdda59ef28a92bfd5742891f63c1fa400db4ef89077fa13d917932d83e76d543c4c326a27df582a025122d8a75f1f7adf0daebbecc42273d4323ff93a SHA512 f200d625d11f76173521f4e2e4e09d57f6613d9b1420c57893b454ec496d5f11b32390b95eb995b403d15f8563b742a58fa0e0cbad42246b4049787a389ad83e
-EBUILD pytest-timeout-2.3.1.ebuild 1070 BLAKE2B dbef48b0368f757406bba30fab73df6044abd36e3ececc9a782f04d6c7589243f930ecfc01488176a9a7223c63c44ea0c34724c71d65c30193a37f97abc1d875 SHA512 901299703bfd066c21634c18742fe9a9873081c45bed34eb87eba35477e1d5a8f1e93602bd118fcc3bb86e354f6c76efd1e62db9182770435bd936228f23e92c
+EBUILD pytest-timeout-2.3.1.ebuild 1147 BLAKE2B ee8ec8feb1a827019ae64bcfb1b0c14a1cad8559689b58abaf6869d14af62d990b967f8cd479a97f712ade3be2137790211a404e646a4fcdb0a2a4fa02d82f62 SHA512 7420e9ceec3e485f4b76973be088baf5154087cb9eb56984fee490fdd716967c9930079c0f14f153a69bfded04cabb4e5d77c53e8640472d3f831955509c288c
MISC metadata.xml 420 BLAKE2B ff56de441243acbf2c7332acf224c8f64427378a8cd5f56c040eca1bcaae467459d8ae09409a963d0053a95035a4e7cfcda067d5be78bcd24ba222b2ce56d6f4 SHA512 c6b4ebdd5bd59452d0952e50526ca9b7cb5b88b12d989947a4775d60cdc9315d594ca7c37cb17c0cd4b2708d08db625f678fd577ac9031e0b0e6dbb364a6ad3a
diff --git a/dev-python/pytest-timeout/pytest-timeout-2.3.1.ebuild b/dev-python/pytest-timeout/pytest-timeout-2.3.1.ebuild
index 2d48986cbf02..cd7abe388b7d 100644
--- a/dev-python/pytest-timeout/pytest-timeout-2.3.1.ebuild
+++ b/dev-python/pytest-timeout/pytest-timeout-2.3.1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
@@ -25,7 +25,9 @@ BDEPEND="
test? (
dev-python/pexpect[${PYTHON_USEDEP}]
!hppa? (
- dev-python/pytest-cov[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ ' python3_{10..11} pypy3)
)
)
"
@@ -37,7 +39,7 @@ python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local -x PYTEST_PLUGINS=pytest_timeout
- if has_version dev-python/pytest-cov; then
+ if has_version "dev-python/pytest-cov[${PYTHON_USEDEP}]"; then
PYTEST_PLUGINS+=,pytest_cov.plugin
else
EPYTEST_DESELECT+=(