summaryrefslogtreecommitdiff
path: root/dev-python/pytest-testinfra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-16 18:48:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-16 18:48:52 +0000
commitf265f17242b04ae036b4dc174fa95401d895dbc5 (patch)
tree8daa848087a673b8bf5dad576b0a08048d551da7 /dev-python/pytest-testinfra
parentd08ea43e9ada434f42f4be8e115b67ab22ce38af (diff)
gentoo auto-resync : 16:03:2024 - 18:48:51
Diffstat (limited to 'dev-python/pytest-testinfra')
-rw-r--r--dev-python/pytest-testinfra/Manifest4
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-10.0.0.ebuild54
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-10.1.0.ebuild2
3 files changed, 2 insertions, 58 deletions
diff --git a/dev-python/pytest-testinfra/Manifest b/dev-python/pytest-testinfra/Manifest
index c4e0df9d8c4c..6abdbf4cf008 100644
--- a/dev-python/pytest-testinfra/Manifest
+++ b/dev-python/pytest-testinfra/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-testinfra-10.0.0.tar.gz 84667 BLAKE2B 10c62340af7cb0a07cbc3c8099f0d22bbf8e3623e8c5f80dd45acef23ec178a2b090aa012e5602c7b67d0ef61ca9922d05e412e8db62384589080455326c8abc SHA512 3f289fccc3ba38ed1aa316adbb05ef74f51fbd1130ab7a39c5d56a11124de96c048aecef3a19438cd0d50d4891ed843671d9daf50fc5c3fb5c834164b276529d
DIST pytest-testinfra-10.1.0.tar.gz 85117 BLAKE2B 3db43661def60ef9627bd888b92f409886f2d6f1ae1306a8d46bbcbe3363cf5ae9e79f9fab49f0d0f8d6529d677a40db04fc68597d0d11e0285a7e27a01283fb SHA512 98003ab250c06fc69ff015fc53af87aa642109866a86bdd679cc8876db614660f11f79c3146aef10c7b8f47723a13777cbad07276af661986129a5d0bfc11e1b
-EBUILD pytest-testinfra-10.0.0.ebuild 1251 BLAKE2B 485d184cc30d34a9686aa92eae680852b64abf1cc30f8e83c017efb8dda50a733d7c8be0fcea509199c2c7edcf9a1d69702d4bae4b3f3aa421b8b5f2afb569fe SHA512 44f83126331bcc0524ff7b7bc060bdd42be69ee6b00e7023a2473cc9a68da106d060b2c4491825e8eb62388ae4a36689140f5ac86605a398854f38bca0426a85
-EBUILD pytest-testinfra-10.1.0.ebuild 1251 BLAKE2B da7cd17fac523227a0ff7750a09cbe3d729121589f7cf251fa4d1d19f8a14c771472c880a26c9901657501027b3d5599c386883857ab4bcd9d2684337cdad886 SHA512 59c77cbf56dd1c1b9ae8e7380dd3e6bf37d28aa5febf18a518d44bfc9f27e4ff5a61d9afca344b9207a071f6794e8ce24866d31fbc023d0c3e9eb6cffa918380
+EBUILD pytest-testinfra-10.1.0.ebuild 1250 BLAKE2B 294debb7495677ab384cc0f8b02a9ba2f6c4ba45cb74607da0ea9457be29514c79059252b3905d6cff2a9fbd2d5739b977bdc059a15552357cb3768e2e79c818 SHA512 5452af12f170b7f4ad630e3f64e4a7c9c0d81841c28385cbea5effd2d058c4bf36051ef9286a63dcece661db6e18794983e4fdf1401a1b2375eb23d3173bcecf
MISC metadata.xml 781 BLAKE2B e38dd6fa967258affb201d6474524e22124a1b8848cff08f3da88e97ff3e13597770c494ee040481967028ee4d82112fb3d38f1034cb7982288d859efe540a21 SHA512 b6c868e77d1202622086340ae284071eaf1b95948c84a8a00f06e819e72325346d7aa226931d1bb5a3f782f23656c1e65f4b21a74ee0cb70deabfd602f774e99
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-10.0.0.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-10.0.0.ebuild
deleted file mode 100644
index e16d835a1bb3..000000000000
--- a/dev-python/pytest-testinfra/pytest-testinfra-10.0.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Write unit tests in Python to test actual state of your servers"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-testinfra/
- https://pypi.org/project/pytest-testinfra/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~riscv"
-
-RDEPEND="
- dev-python/pytest[${PYTHON_USEDEP}]
-"
-# Ansible is called via its CLI
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- app-admin/ansible
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/pywinrm[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x EPYTEST_DESELECT=()
-
- # This is the only test which actually fails if salt cannot be imported
- if ! has_version "dev-python/salt[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- test/test_backends.py::test_backend_importables
- )
- fi
-
- epytest
-}
-
-pkg_postinst() {
- elog "For the list of available connection back-ends and their dependencies,"
- elog "please consult https://testinfra.readthedocs.io/en/latest/backends.html"
-}
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-10.1.0.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-10.1.0.ebuild
index cb998a1104af..6a6eef4cb700 100644
--- a/dev-python/pytest-testinfra/pytest-testinfra-10.1.0.ebuild
+++ b/dev-python/pytest-testinfra/pytest-testinfra-10.1.0.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 arm64 ~riscv"
+KEYWORDS="amd64 arm64 ~riscv"
RDEPEND="
dev-python/pytest[${PYTHON_USEDEP}]