summaryrefslogtreecommitdiff
path: root/dev-python/pytest-testinfra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-25 15:54:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-25 15:54:35 +0100
commitd0bb3151c569ab6e40c84c177f43bff3c7ce4780 (patch)
tree0c543a2f299a437229bcd5db5c62697a41243689 /dev-python/pytest-testinfra
parent601320c16301dbd7e8830e8c2ab7d6aef5b65abe (diff)
gentoo auto-resync : 25:08:2023 - 15:54:35
Diffstat (limited to 'dev-python/pytest-testinfra')
-rw-r--r--dev-python/pytest-testinfra/Manifest2
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-9.0.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pytest-testinfra/Manifest b/dev-python/pytest-testinfra/Manifest
index 3e9f9e69e38a..ce6d05b34eb7 100644
--- a/dev-python/pytest-testinfra/Manifest
+++ b/dev-python/pytest-testinfra/Manifest
@@ -1,3 +1,5 @@
DIST pytest-testinfra-8.1.0.tar.gz 84156 BLAKE2B 169ccd6afc4260f3dd42c8eff8112395adc7216cfd3e5f7abeb9b9d3db0cd766465dd94a5ca500d610db469f0e51298b6fc26f3c0ffd27f2fc215d859c99e52d SHA512 2f98cc15952c5607ecc1db76bae90aa9d299951cd1f4c5f8ba6085a7f4e6babac7f4ef4e44e089829f7382139164259007125f505c18129cc7135b840d709931
+DIST pytest-testinfra-9.0.0.tar.gz 83896 BLAKE2B 8d75bf051ec91916dcb9bc727409eefbf53f8635b5dd953d2c1d05a1d4daa37ade01a23bcc004f77ced37d8fb30684df211d16d95839c1a8d8e5d5c4df5336ca SHA512 bbf66597c473b868f0dde0437d666f8235e835a35bfd12b4a86f9970e26c1963d83101e7e0e3b3817e23798bee342f47ac7666041f0e09038236f9ddca4afecf
EBUILD pytest-testinfra-8.1.0.ebuild 1260 BLAKE2B fe19b1fea4838b317c9b907038b8cc1e011962ce06848dcd92301317f8858165188619c426d0a6cccc1f61a0b8416690d7654d47af2d9706f7e19645aea748c9 SHA512 5a55ceb371007dcb2a05205eb7bbffd8fa7d66dd4aee1e7c664c56b7e47b45375b9060a5cea9e1f38bbc49bb54c3f07adfc56a3e2f4b753673d4075e8b92fae8
+EBUILD pytest-testinfra-9.0.0.ebuild 1323 BLAKE2B cae4f1e937e04d6354324071aac8e74604924b9b987f3546a9e58c34a68e91581a0c814519676b59b59a63f589a16b5f8b2a4e75cd56fe5b6b94264859aab626 SHA512 9875e940d8fb1fc96184573a5cfee5805db44e1aa7d95a3ff2bd518a6f3d8c4d3daf96370a0f1a33980d9b1699e0fe5383918e839c6976c6acdc957f54cc08e3
MISC metadata.xml 781 BLAKE2B e38dd6fa967258affb201d6474524e22124a1b8848cff08f3da88e97ff3e13597770c494ee040481967028ee4d82112fb3d38f1034cb7982288d859efe540a21 SHA512 b6c868e77d1202622086340ae284071eaf1b95948c84a8a00f06e819e72325346d7aa226931d1bb5a3f782f23656c1e65f4b21a74ee0cb70deabfd602f774e99
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-9.0.0.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-9.0.0.ebuild
new file mode 100644
index 000000000000..6af6abc9e956
--- /dev/null
+++ b/dev-python/pytest-testinfra/pytest-testinfra-9.0.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Write unit tests in Python to test actual state of your servers"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-testinfra/
+ https://pypi.org/project/pytest-testinfra/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+# Ansible is called via its CLI
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ app-admin/ansible
+ $(python_gen_cond_dep '
+ app-admin/salt[${PYTHON_USEDEP}]
+ ' python3_10)
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pywinrm[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x EPYTEST_DESELECT=()
+
+ # This is the only test which actually fails if salt cannot be imported
+ if ! has_version "dev-python/salt[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ test/test_backends.py::test_backend_importables
+ )
+ fi
+
+ epytest
+}
+
+pkg_postinst() {
+ elog "For the list of available connection back-ends and their dependencies,"
+ elog "please consult https://testinfra.readthedocs.io/en/latest/backends.html"
+}