summaryrefslogtreecommitdiff
path: root/dev-python/pytest-testinfra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-14 10:30:49 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-14 10:30:49 +0000
commitcd8b6c60f3cbb06647bf3d03fb2ac29ccfc31c8f (patch)
tree2e3b9d43dc19a31fee73728c8a91e2e02e6b243e /dev-python/pytest-testinfra
parent62ce4dfbf01c603a668dabde87ccc5b4ca4069af (diff)
gentoo auto-resync : 14:11:2023 - 10:30:49
Diffstat (limited to 'dev-python/pytest-testinfra')
-rw-r--r--dev-python/pytest-testinfra/Manifest2
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-10.0.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pytest-testinfra/Manifest b/dev-python/pytest-testinfra/Manifest
index 87dcf4b9eba5..bf44aca50eb7 100644
--- a/dev-python/pytest-testinfra/Manifest
+++ b/dev-python/pytest-testinfra/Manifest
@@ -1,3 +1,5 @@
+DIST pytest-testinfra-10.0.0.tar.gz 84667 BLAKE2B 10c62340af7cb0a07cbc3c8099f0d22bbf8e3623e8c5f80dd45acef23ec178a2b090aa012e5602c7b67d0ef61ca9922d05e412e8db62384589080455326c8abc SHA512 3f289fccc3ba38ed1aa316adbb05ef74f51fbd1130ab7a39c5d56a11124de96c048aecef3a19438cd0d50d4891ed843671d9daf50fc5c3fb5c834164b276529d
DIST pytest-testinfra-9.0.0.tar.gz 83896 BLAKE2B 8d75bf051ec91916dcb9bc727409eefbf53f8635b5dd953d2c1d05a1d4daa37ade01a23bcc004f77ced37d8fb30684df211d16d95839c1a8d8e5d5c4df5336ca SHA512 bbf66597c473b868f0dde0437d666f8235e835a35bfd12b4a86f9970e26c1963d83101e7e0e3b3817e23798bee342f47ac7666041f0e09038236f9ddca4afecf
+EBUILD pytest-testinfra-10.0.0.ebuild 1323 BLAKE2B cae4f1e937e04d6354324071aac8e74604924b9b987f3546a9e58c34a68e91581a0c814519676b59b59a63f589a16b5f8b2a4e75cd56fe5b6b94264859aab626 SHA512 9875e940d8fb1fc96184573a5cfee5805db44e1aa7d95a3ff2bd518a6f3d8c4d3daf96370a0f1a33980d9b1699e0fe5383918e839c6976c6acdc957f54cc08e3
EBUILD pytest-testinfra-9.0.0.ebuild 1322 BLAKE2B 88cc12d0b6f9452f1bf4f9cff36e008d12cf715c5b6e0ed7c74846d193f1129ebe1bf3b52d2ed70c020a2f885721b44fc383bf2dfc86ad91effb299e4c73ed9b SHA512 750d48a9e204a3a28c34e1378210d80b162ca6fadcf0477512a6168d82e31ec369cae3d03c9c3a038b62a0e9f828a6e8d7315c1fa22a11dd777ba223841dfa1d
MISC metadata.xml 781 BLAKE2B e38dd6fa967258affb201d6474524e22124a1b8848cff08f3da88e97ff3e13597770c494ee040481967028ee4d82112fb3d38f1034cb7982288d859efe540a21 SHA512 b6c868e77d1202622086340ae284071eaf1b95948c84a8a00f06e819e72325346d7aa226931d1bb5a3f782f23656c1e65f4b21a74ee0cb70deabfd602f774e99
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-10.0.0.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-10.0.0.ebuild
new file mode 100644
index 000000000000..6af6abc9e956
--- /dev/null
+++ b/dev-python/pytest-testinfra/pytest-testinfra-10.0.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Write unit tests in Python to test actual state of your servers"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-testinfra/
+ https://pypi.org/project/pytest-testinfra/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+# Ansible is called via its CLI
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ app-admin/ansible
+ $(python_gen_cond_dep '
+ app-admin/salt[${PYTHON_USEDEP}]
+ ' python3_10)
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pywinrm[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x EPYTEST_DESELECT=()
+
+ # This is the only test which actually fails if salt cannot be imported
+ if ! has_version "dev-python/salt[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ test/test_backends.py::test_backend_importables
+ )
+ fi
+
+ epytest
+}
+
+pkg_postinst() {
+ elog "For the list of available connection back-ends and their dependencies,"
+ elog "please consult https://testinfra.readthedocs.io/en/latest/backends.html"
+}