summaryrefslogtreecommitdiff
path: root/dev-python/pytest-testinfra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/pytest-testinfra
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/pytest-testinfra')
-rw-r--r--dev-python/pytest-testinfra/Manifest2
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-6.5.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-testinfra/Manifest b/dev-python/pytest-testinfra/Manifest
index aabdc6f91dae..39427a8d9c56 100644
--- a/dev-python/pytest-testinfra/Manifest
+++ b/dev-python/pytest-testinfra/Manifest
@@ -1,3 +1,5 @@
DIST pytest-testinfra-6.4.0.tar.gz 77516 BLAKE2B 2baf5940e8736cbe78d8017a82b3a8fdb6df95b89acccd49ecd354447b7ea88079f48211e0acea46a0d8702b67609fe6f85f730c66e781a99d8a92b52b3c99b9 SHA512 acd2c7f9daeb391815a32c972a3542c0d643a716f3cffcb66f4203435ebac789333edb91c83d2778ae8da93b676b245fd47821bca9218faa3e7b50e6764087f4
+DIST pytest-testinfra-6.5.0.tar.gz 77177 BLAKE2B 98a8f10f7cf62f204c117d295496a7dfa4de476f5cde457af6f5bc71b22e12e9f02b4893adc6b0d1be11915ed652f628c2574fd44750c82c690e3d8326e29c4c SHA512 f7fcf8facafc0d99b06f55f4241c39b610ff7648b0049c584a75b46944b522b957c98c353f147d74bc8a72f677a179380c456b0868f9dae9af514a9c95d55b13
EBUILD pytest-testinfra-6.4.0.ebuild 894 BLAKE2B 1027b8c0a4d13d2db3612bd989f32414316fef63fb7a265682ae8dc5b992f886e6c2592f2645789abdf70bad3a4a12742c584645bbce974fe513b680cc5890cc SHA512 2b957be685f8e7961aa05093dfaa14783e79107becf42c6668a7b3c0d75b660bff45c05ac9f7f9c50e4c2cf068cefb8d3e4d6f78477ac5f9553ae8478c0438e0
+EBUILD pytest-testinfra-6.5.0.ebuild 894 BLAKE2B 1027b8c0a4d13d2db3612bd989f32414316fef63fb7a265682ae8dc5b992f886e6c2592f2645789abdf70bad3a4a12742c584645bbce974fe513b680cc5890cc SHA512 2b957be685f8e7961aa05093dfaa14783e79107becf42c6668a7b3c0d75b660bff45c05ac9f7f9c50e4c2cf068cefb8d3e4d6f78477ac5f9553ae8478c0438e0
MISC metadata.xml 680 BLAKE2B feb779de8bbaf041a3aa00046c4b17fcad0e863ebd365732c9f1e0bbdf6c68edf7ec2b7d546c2bdf458c134f7cb17a65ba07fe6edb5af7675d4bb79af75a23a6 SHA512 386a4877ca43ef6a1408ecc0871ba40c40b4654ee3824b4a99f5ff6f4769284d54c9377cebcd5456815fc5470110a337d83f8016a6598cef8ce29d93cd3645fc
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-6.5.0.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-6.5.0.ebuild
new file mode 100644
index 000000000000..c336646d0373
--- /dev/null
+++ b/dev-python/pytest-testinfra/pytest-testinfra-6.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Write unit tests in Python to test actual state of your servers"
+HOMEPAGE="https://github.com/pytest-dev/pytest-testinfra"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+# Ansible is called via its CLI
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ app-admin/ansible
+ app-admin/salt[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pywinrm[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ elog "For the list of available connection back-ends and their dependencies,"
+ elog "please consult https://testinfra.readthedocs.io/en/latest/backends.html"
+}