summaryrefslogtreecommitdiff
path: root/dev-python/pytest-testinfra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-20 10:17:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-20 10:17:50 +0100
commit399fa07bfac673a8846466b16c76549e329b55b8 (patch)
tree29af17ef91f1bd986b8e615a96b61db7fad5df14 /dev-python/pytest-testinfra
parent388a0747e5972613060d5ca13955b5cd7132533d (diff)
gentoo auto-resync : 20:05:2023 - 10:17:50
Diffstat (limited to 'dev-python/pytest-testinfra')
-rw-r--r--dev-python/pytest-testinfra/Manifest2
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-8.0.0.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/pytest-testinfra/Manifest b/dev-python/pytest-testinfra/Manifest
index 73d9fb8156a3..3f4439bd7abb 100644
--- a/dev-python/pytest-testinfra/Manifest
+++ b/dev-python/pytest-testinfra/Manifest
@@ -1,3 +1,5 @@
DIST pytest-testinfra-7.0.0.tar.gz 79296 BLAKE2B b0870cbf466627daff0ed6a3063c15c9b725fab4009fc24c3779b56765901e6b8d3a42fce429f1e42151b78d61f52c38955772e562c74d78c717a61a5fe74f04 SHA512 507d7a434c2eb159e2c36b1be3d447e386d3a4e614f2717ed8add456358f644c18f801db6774a4854e4ec7936643febd332aa4096ab26ae0080aceeff420c78e
+DIST pytest-testinfra-8.0.0.tar.gz 83448 BLAKE2B e1dcd7f685183ad0d1c79f3fe7542797f2c91839faf79e2b368c0e330aec22a420621859d419f7816b72df4aad9ac9d5ecc99d257804311d6b8b77c20b5b833b SHA512 ee8e8df7ba0422ea60d55149495a682b88a62646b6b601dd95a135a5d3a131d5cc57cb0f0cc0ff7166d004758619283480e52b8507cc2eedbc25c46a16da60b5
EBUILD pytest-testinfra-7.0.0.ebuild 1454 BLAKE2B 99d367bbee7868a9b20bc690ad8398ddce1c03c6ccf4ab78a53e95a704f1d2a7054fc7f123d7fbd66db0d668b30fb4bb25c8bdf1c829287ced0cdc34071210f8 SHA512 4a3d9f22069599696f8c594057a793e4cc87b9640a96a2290baba54fd11aa435efd0edd4e7146d9bb76f62e6c282158ce45466525fb02a3729a3c0222ce6bec1
+EBUILD pytest-testinfra-8.0.0.ebuild 1261 BLAKE2B d936c56d8662461d2d05629cfe95557fb3cc87ebd9ae6c03ea29ebdc88da0f8fc10708ff1bc72f80d5c3ff14dc94467ad25384c629ee311f570dacc21989dd61 SHA512 dd0530b7e16b2aeb569d676c80caa9988064ee8763f7cc7b98e489d85e64ba3d95ac7e752a1286e5929dd9b72d2152e12a2d3cd8f141fb16131e1f36fe4385fa
MISC metadata.xml 781 BLAKE2B e38dd6fa967258affb201d6474524e22124a1b8848cff08f3da88e97ff3e13597770c494ee040481967028ee4d82112fb3d38f1034cb7982288d859efe540a21 SHA512 b6c868e77d1202622086340ae284071eaf1b95948c84a8a00f06e819e72325346d7aa226931d1bb5a3f782f23656c1e65f4b21a74ee0cb70deabfd602f774e99
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-8.0.0.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-8.0.0.ebuild
new file mode 100644
index 000000000000..ac3689c80baf
--- /dev/null
+++ b/dev-python/pytest-testinfra/pytest-testinfra-8.0.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Write unit tests in Python to test actual state of your servers"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-testinfra/
+ https://pypi.org/project/pytest-testinfra/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+# Ansible is called via its CLI
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ app-admin/ansible
+ $(python_gen_cond_dep '
+ app-admin/salt[${PYTHON_USEDEP}]
+ ' python3_10)
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pywinrm[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x EPYTEST_DESELECT=()
+
+ # This is the only test which actually fails if salt cannot be imported
+ if [[ ${EPYTHON} == python3.11 ]]; then
+ EPYTEST_DESELECT+=(
+ test/test_backends.py::test_backend_importables
+ )
+ fi
+
+ epytest
+}
+
+pkg_postinst() {
+ elog "For the list of available connection back-ends and their dependencies,"
+ elog "please consult https://testinfra.readthedocs.io/en/latest/backends.html"
+}