summaryrefslogtreecommitdiff
path: root/dev-python/pytest-sugar/pytest-sugar-0.9.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-05 15:18:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-05 15:18:09 +0000
commitc66fa6cf106b825bcc6f1beeff9486ff08232cbe (patch)
treed5147c1533df62427a098f373049d1ec15a7fbc3 /dev-python/pytest-sugar/pytest-sugar-0.9.6.ebuild
parent54c42eb42df420f52e032fcba7727c326ef01094 (diff)
gentoo auto-resync : 05:11:2022 - 15:18:09
Diffstat (limited to 'dev-python/pytest-sugar/pytest-sugar-0.9.6.ebuild')
-rw-r--r--dev-python/pytest-sugar/pytest-sugar-0.9.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-sugar/pytest-sugar-0.9.6.ebuild b/dev-python/pytest-sugar/pytest-sugar-0.9.6.ebuild
new file mode 100644
index 000000000000..edf438421a2e
--- /dev/null
+++ b/dev-python/pytest-sugar/pytest-sugar-0.9.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin that changes the default look and feel of pytest"
+HOMEPAGE="
+ https://github.com/Teemu/pytest-sugar/
+ https://pypi.org/project/pytest-sugar/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest