summaryrefslogtreecommitdiff
path: root/dev-python/pytest-subtests
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-16 08:04:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-16 08:04:03 +0000
commit97f40b36b1afa9726e32962d11f3ac2d0bc5792e (patch)
tree1c7d586bc8a53d3b768630527bb80a477d661fa3 /dev-python/pytest-subtests
parentb435e036d9775b71048373b91d4c7c3398826858 (diff)
gentoo auto-resync : 16:02:2023 - 08:04:02
Diffstat (limited to 'dev-python/pytest-subtests')
-rw-r--r--dev-python/pytest-subtests/Manifest2
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.10.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pytest-subtests/Manifest b/dev-python/pytest-subtests/Manifest
index 825bd6f23774..67a607eeafd8 100644
--- a/dev-python/pytest-subtests/Manifest
+++ b/dev-python/pytest-subtests/Manifest
@@ -1,3 +1,5 @@
+DIST pytest-subtests-0.10.0.gh.tar.gz 10253 BLAKE2B dba434dfc3f27293d5576ad408665917394ff54d41aef5604f40d787c4d7d9c6fc42b99ca10a8d46707fc8ce0eb5aab8e27bb32b464f5c9350f6bda6b12df031 SHA512 2fc3f8316db879d64d4dd4ad53df7dbda30b69df9291608eb6235aa27e9e6b3ec4174023f9ffa016811eb8955f0ebd673ead7b7319d927d18d7c016e0c7ef573
DIST pytest-subtests-0.9.0.gh.tar.gz 9840 BLAKE2B c94155c1e44b4bf81bc4d2d1963c952b721634372db9dc5c1b8a7819acba8e84815333c0c67a90d2a930abb98affbd99a721796ed09513635923f6a89e336d4a SHA512 f1bc2b99e6f04864cdc45675574d32821fd5e08c01c937bddc846ac509cd8906d21ee63b11e9e8a87c2631334541e9adc601a7dd69702572d51c3d4b72443ad2
+EBUILD pytest-subtests-0.10.0.ebuild 1101 BLAKE2B 589983825e864a167acb5802daf003c40fc22305a165f6e84a5139b08b769e05c5ae5de4f5b215f05886de5528b22e10721658a4c9011455202c67d275486084 SHA512 9346b2380fe7948801b91fdf67448fda10f6e5cdcbe97f4b49ebcc3ab315e2c2475cd6cddc9075f4f6686960067c9c15435ef9fb8947a50b354b5f999e811c50
EBUILD pytest-subtests-0.9.0.ebuild 1048 BLAKE2B f66fa69d080b44fd6980e17d1acf7b778c63e2f32b147498947568a7a9966527701dcb074b0a981a8f7afa56e04fb008c5017db39b8a85b46671ff34025eddad SHA512 80592da39ceaea660a43e24f5dbfb7bd05bb1cf1b51e91d38de6c791bc9cb657c972f0967207dce210635d5efe71d25e24774b30eaa037a552ef449c7e3743e3
MISC metadata.xml 409 BLAKE2B ca267dc80fa124c3c8ba82f5e46356492e8cadefcf8001469c3c076b079844ae72829b5b527658bea341c3fee3f173421c9f2e7ec7042a171e234070113f4734 SHA512 57c12735a910107b53dbe54969f15ce70eafda3df096c78082d91d5bedc53b015ecae3e3d901e0a2a90841370916f6e4e94041e0b5589ffdce323144375e6c20
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.10.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.10.0.ebuild
new file mode 100644
index 000000000000..82a381512d9d
--- /dev/null
+++ b/dev-python/pytest-subtests/pytest-subtests-0.10.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="unittest subTest() support and subtests fixture"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-subtests/
+ https://pypi.org/project/pytest-subtests/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-subtests/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7[${PYTHON_USEDEP}]
+"
+# pytest-xdist is used to test compatibility
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked,pytest_subtests
+ epytest
+}