summaryrefslogtreecommitdiff
path: root/dev-python/pytest-subtests
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-29 10:01:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-29 10:01:01 +0100
commit8ba401288d74259a5fd8e9de5241dd57a0a73b1f (patch)
treee49dac129b06e1a0a410f4c1b91581ea02d582ff /dev-python/pytest-subtests
parent746652e918ce7328c0cc5ffef8a79146b91ba21b (diff)
gentoo auto-resync : 29:10:2022 - 10:01:00
Diffstat (limited to 'dev-python/pytest-subtests')
-rw-r--r--dev-python/pytest-subtests/Manifest2
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.9.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pytest-subtests/Manifest b/dev-python/pytest-subtests/Manifest
index 26ccdcde07dc..c4ae6e19cc96 100644
--- a/dev-python/pytest-subtests/Manifest
+++ b/dev-python/pytest-subtests/Manifest
@@ -1,3 +1,5 @@
DIST pytest-subtests-0.8.0.gh.tar.gz 9767 BLAKE2B 707f6744f1cd7723d7bee11f5e535750fa179e7ad3912cd94d5200002e1dc0a206cbdb5c3bc8be587a1c81342ef9d6a8a397acd08388096a484feca6f9c84e0c SHA512 0164e02c81685108bb5c12f7e7ce92dc2fd5c844be454b2cb26e3cb942d51c453f06bb48e0300438a82b28c747dea35ea4f75eaf65ff8b66b338bcb0f0dd9ed1
+DIST pytest-subtests-0.9.0.gh.tar.gz 9840 BLAKE2B c94155c1e44b4bf81bc4d2d1963c952b721634372db9dc5c1b8a7819acba8e84815333c0c67a90d2a930abb98affbd99a721796ed09513635923f6a89e336d4a SHA512 f1bc2b99e6f04864cdc45675574d32821fd5e08c01c937bddc846ac509cd8906d21ee63b11e9e8a87c2631334541e9adc601a7dd69702572d51c3d4b72443ad2
EBUILD pytest-subtests-0.8.0.ebuild 1377 BLAKE2B b007cfbe785cd0a779778f0deb676e5f447995d1d3959218b36f7ec0302c927853eac31b9dec45dd150fe7732cc9bf0f7695c6a6342ddb48dd715fda7383ef6d SHA512 fd9032fa6333d5af9885f7aab509977b5011b36bba61ab9f6470f14f5fc79e790aa49f90e88ab9dc0c6c7d931c66e79e9b9e2fc9366bea6d05d467b1ae403d05
+EBUILD pytest-subtests-0.9.0.ebuild 1051 BLAKE2B 614a399f1db34e934e2497548b6321471ef71c1e14eda500577cd2b2090c8799fadc99499803a36baf8cabb0a2e0a3cbe15daa1ec9aad6bcd37cbaebc18cfa31 SHA512 f5db357244c0249f7b47b051e09556682bc838af7e95f9ee954ade7d37056567946a84bc0fe799677c2efce50d9567f04e0b9237598a76ae9b5fa7a092c024ad
MISC metadata.xml 409 BLAKE2B ca267dc80fa124c3c8ba82f5e46356492e8cadefcf8001469c3c076b079844ae72829b5b527658bea341c3fee3f173421c9f2e7ec7042a171e234070113f4734 SHA512 57c12735a910107b53dbe54969f15ce70eafda3df096c78082d91d5bedc53b015ecae3e3d901e0a2a90841370916f6e4e94041e0b5589ffdce323144375e6c20
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.9.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.9.0.ebuild
new file mode 100644
index 000000000000..306785062506
--- /dev/null
+++ b/dev-python/pytest-subtests/pytest-subtests-0.9.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="unittest subTest() support and subtests fixture"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-subtests/
+ https://pypi.org/project/pytest-subtests/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-subtests/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7[${PYTHON_USEDEP}]
+"
+# pytest-xdist is used to test compatibility
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked,pytest_subtests
+ epytest
+}