summaryrefslogtreecommitdiff
path: root/dev-python/pytest-subtests
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-python/pytest-subtests
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-python/pytest-subtests')
-rw-r--r--dev-python/pytest-subtests/Manifest4
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild36
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.5.0.ebuild2
3 files changed, 2 insertions, 40 deletions
diff --git a/dev-python/pytest-subtests/Manifest b/dev-python/pytest-subtests/Manifest
index 403a131c6866..8316192eb8c0 100644
--- a/dev-python/pytest-subtests/Manifest
+++ b/dev-python/pytest-subtests/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-subtests-0.4.0.tar.gz 9673 BLAKE2B 780fbbdc6d4ac88c87002ee14323a0dd1036ab3dadc14b79ef11982459c60635add77e97575521ba0bda61317582e090353b427d945eca7198e294eb3d895240 SHA512 00302f47d1699e053314b6b4eee7c84a04fe0f51f287e338374bbd518c7d245d839ea0f1ccf50d4f35c86138cf6ea36da26e67bf41295205fb38323f2ad89f89
DIST pytest-subtests-0.5.0.tar.gz 9793 BLAKE2B c671eb14189c0fd34180a636592b20c9e2b4225c5faf3b702103164e60bdbac4c9644e464f1e0c783da3da1263f7b841ea7a4149bcbf1de23325a8ef3ce5c030 SHA512 e3d7e90c3ab66950eb80d25049bc6f6f75b08b3da5ce0de5f3fc55d6a176a8d1fdcb19a19f7d9d137aeadcc82b214550474f76d5611bc5592ca649ddd8257a2a
-EBUILD pytest-subtests-0.4.0.ebuild 920 BLAKE2B 758191563212f5086dca9396df801ee6889ee69414c3a8cd1543a954d80b7e5cc36c4799f215caafccc2d7f2fb8735b6801f207d1e8a3b19787f3ac4337dbc5f SHA512 120b66684fb9219f4eac5e6c373ab7ae7d29bde2b393450909473dc9282c336c89315a04439447ba7ae70ae44a77f33fff9c262e3691115cbfcba946a79be347
-EBUILD pytest-subtests-0.5.0.ebuild 928 BLAKE2B dbdc1d767d5f3976961ab7b5535fb5ab0f8fa0c7bbac87755f2506154214e77ac4754f5648bd5d8d7c118cf5eb713098cb1451bc86e429548fdacd54b331961c SHA512 c09f96acaf1f0c9a5cccdd3fecbfaf4d4a70172f1bdabc9d7b3397848ab0ea2ad916cb71d5730b70de8677217ef6aa7fd38694194501d5c4129272c4b79032d0
+EBUILD pytest-subtests-0.5.0.ebuild 920 BLAKE2B 758191563212f5086dca9396df801ee6889ee69414c3a8cd1543a954d80b7e5cc36c4799f215caafccc2d7f2fb8735b6801f207d1e8a3b19787f3ac4337dbc5f SHA512 120b66684fb9219f4eac5e6c373ab7ae7d29bde2b393450909473dc9282c336c89315a04439447ba7ae70ae44a77f33fff9c262e3691115cbfcba946a79be347
MISC metadata.xml 408 BLAKE2B 6aa0bbf41b922dcd85d121ac03cb177f2527c8bf89eebb53bbcf86bb3e551e2023c38a1356f1cb5c55010bf65c97f95ca77d9aa26db8e898ed1bb74133825a6e SHA512 5485b50b9c2f5f23209931bdb2afdea6bf77bd55d2853aea2418691fcd9fd93c47bf4ba3c5769cdfa5240e463b7926a8fe5f0a0795464fa02d46fc61e8dd59a3
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild
deleted file mode 100644
index 96ccd96fda1b..000000000000
--- a/dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="unittest subTest() support and subtests fixture"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-subtests/
- https://pypi.org/project/pytest-subtests/"
-SRC_URI="
- https://github.com/pytest-dev/pytest-subtests/archive/refs/tags/${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
-
-RDEPEND="
- >=dev-python/pytest-5.3.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/typing-extensions
- ' python3_7 pypy3)
-"
-# pytest-xdist is used to test compatibility
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests --install pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.5.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.5.0.ebuild
index 0182bfadbb1c..96ccd96fda1b 100644
--- a/dev-python/pytest-subtests/pytest-subtests-0.5.0.ebuild
+++ b/dev-python/pytest-subtests/pytest-subtests-0.5.0.ebuild
@@ -16,7 +16,7 @@ SRC_URI="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
RDEPEND="
>=dev-python/pytest-5.3.0[${PYTHON_USEDEP}]