summaryrefslogtreecommitdiff
path: root/dev-python/pytest-subtests
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-16 10:06:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-16 10:06:32 +0100
commit11263cb7c372230b9e5c0195c24692e299887573 (patch)
tree6da3f9cf32762190d60c9dc5f5665b6f6b112833 /dev-python/pytest-subtests
parentd7665b9dae37c3b9a1c72157fdf49c101bd6495e (diff)
gentoo auto-resync : 16:05:2023 - 10:06:32
Diffstat (limited to 'dev-python/pytest-subtests')
-rw-r--r--dev-python/pytest-subtests/Manifest2
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.11.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pytest-subtests/Manifest b/dev-python/pytest-subtests/Manifest
index 46ef92608bc9..eebbf2f92779 100644
--- a/dev-python/pytest-subtests/Manifest
+++ b/dev-python/pytest-subtests/Manifest
@@ -1,3 +1,5 @@
DIST pytest-subtests-0.10.0.gh.tar.gz 10253 BLAKE2B dba434dfc3f27293d5576ad408665917394ff54d41aef5604f40d787c4d7d9c6fc42b99ca10a8d46707fc8ce0eb5aab8e27bb32b464f5c9350f6bda6b12df031 SHA512 2fc3f8316db879d64d4dd4ad53df7dbda30b69df9291608eb6235aa27e9e6b3ec4174023f9ffa016811eb8955f0ebd673ead7b7319d927d18d7c016e0c7ef573
+DIST pytest-subtests-0.11.0.tar.gz 12763 BLAKE2B b1e1373d197798a9c27ed65569a681e9ea8dd36014cf6ea57a1d44ed888dca21bd8c5afffeb7f590a501d83d1bc0a8e1fe06b13832173e6937b722163614f21e SHA512 cab486252148e457e234e0dadacefa5ff38cf67df48d9c8bd61aa546a4a1e712b70dca0a270dffceede6be0f8a6324e8c21beaa4d1528b39f12bba72e077ef1d
EBUILD pytest-subtests-0.10.0.ebuild 1093 BLAKE2B cb0e716345b486db38f6e230cfda8114dcf7e23f1442c4857d8ea5c7bb44aa25f181edd10d13c38420ddd38c4a20b4333074ad06c6a8e1299c45821816730e6e SHA512 05a9548df6ef4a604f533dc2b6b1f5f6e2c770b9774358011f0ab81f9fe61e72853ddda4d9f9d23be55cd8db65dd03a3019107359c74a400a083fcb5c874de7a
+EBUILD pytest-subtests-0.11.0.ebuild 973 BLAKE2B dec02247024d1eb51506f4883c7650f56f785ed044d1d72b2debd4fed767dde7ec56dd511d5aa5c532ace5d205b4b6cb2ab7398ad53d3ca321b1544bacb80f36 SHA512 8a7b14611edbc22fe3947212133fd9de4ad8bd8c1fa9c1477613109c5ce7f609b1e77f5b46b88f1ea16447b37084f8a88b21d33b1126e5c7d2a73fd7ecec02b0
MISC metadata.xml 409 BLAKE2B ca267dc80fa124c3c8ba82f5e46356492e8cadefcf8001469c3c076b079844ae72829b5b527658bea341c3fee3f173421c9f2e7ec7042a171e234070113f4734 SHA512 57c12735a910107b53dbe54969f15ce70eafda3df096c78082d91d5bedc53b015ecae3e3d901e0a2a90841370916f6e4e94041e0b5589ffdce323144375e6c20
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.11.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.11.0.ebuild
new file mode 100644
index 000000000000..b10cb02ed428
--- /dev/null
+++ b/dev-python/pytest-subtests/pytest-subtests-0.11.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Unittest subTest() support and subtests fixture"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-subtests/
+ https://pypi.org/project/pytest-subtests/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7[${PYTHON_USEDEP}]
+"
+# pytest-xdist is used to test compatibility
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked,pytest_subtests
+ epytest
+}