summaryrefslogtreecommitdiff
path: root/dev-python/pytest-subtests/pytest-subtests-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-python/pytest-subtests/pytest-subtests-0.5.0.ebuild
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-python/pytest-subtests/pytest-subtests-0.5.0.ebuild')
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.5.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.5.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.5.0.ebuild
deleted file mode 100644
index 08e73d0d2828..000000000000
--- a/dev-python/pytest-subtests/pytest-subtests-0.5.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="unittest subTest() support and subtests fixture"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-subtests/
- https://pypi.org/project/pytest-subtests/"
-SRC_URI="
- https://github.com/pytest-dev/pytest-subtests/archive/refs/tags/${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/pytest-5.3.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/typing-extensions
- ' python3_7 pypy3)
-"
-# pytest-xdist is used to test compatibility
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests --install pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}