summaryrefslogtreecommitdiff
path: root/dev-python/pytest-subtesthack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/pytest-subtesthack
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/pytest-subtesthack')
-rw-r--r--dev-python/pytest-subtesthack/Manifest2
-rw-r--r--dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-subtesthack/Manifest b/dev-python/pytest-subtesthack/Manifest
index b5363dd5fb27..a609541c3934 100644
--- a/dev-python/pytest-subtesthack/Manifest
+++ b/dev-python/pytest-subtesthack/Manifest
@@ -1,3 +1,5 @@
DIST pytest-subtesthack-0.1.1.tar.gz 2410 BLAKE2B 3d41950ad46bb07da145db7f88eba7eb34a2bbb99273f47d2443cae5ab0e11737f1c2fe81bf473180178b2ad9e55b252c7717846f1b010cc58fb1bf61380d003 SHA512 0bf6425b535e65dc7f06f74493d10fbb6451e78a817174638661d7525f39f092f67db8da010228cbd54b400485e71e443118f91ebef660b9c00d2b354062a55f
+DIST pytest-subtesthack-0.1.2.tar.gz 2669 BLAKE2B f1f5a052f9418732de4a97ff438d280d177860439e667e29ff0d0503740e009c88046b5ba859884e5fa9e958ea1be7388d7fc6838c19e44075ab0ef757ee41c7 SHA512 ddb7b0c27f912bec31e58ddc54930e229755df8980d146c861f7f1c766ae742b4f1552117d89638bdbd443f22890262320a56565954ebc6deeae6184f459a5a8
EBUILD pytest-subtesthack-0.1.1.ebuild 833 BLAKE2B 55220d71cf86b50c3a9801123dd06233fe9ff01f47babba633aea1de94194c6f27735ea196cad4a23fdd91ec0556c50d4d2d741f45e642ffd98b1b21f792d117 SHA512 187d4357c022af5a81f846007317a7b387871f7c8b75415e14ddd5e46d64a773fafc4639cc10ee92e9f5d165689f65a9645a99fb32d2577e622b9e949742b20d
+EBUILD pytest-subtesthack-0.1.2.ebuild 649 BLAKE2B b694de73008954d2820921174c8fcf279177fcfdbc00aef23a4bc8accb0d3ce7c0f88ab33ee53cfe0c9022c3ab6b9e9c9edc654b62493640ab4712b8c6701750 SHA512 62dda8959d4fb47ee251f98f35852ea1254ca34826c8492eb881f9d2b6b261fe49bca0bcd56f86c392a8ffb4f7cfd29c580803d1dad1813e777444e9c3542377
MISC metadata.xml 389 BLAKE2B c1a64baf73ac4190b139a5e39f1b01eb379aa6bde70466ea4a71d97bf92624decbdc0a41a78ae5f1e2e9d95a2ff59c98bbb80a91bb30e0f6be0a11797268747f SHA512 e8be63576ae72a296ac1d11ddebc32611bfddd1ce398d6a5f224dcd627e157fff96536d7bd32e2ed9b5cd872834ef4c85c9b84e10578526a4e6a8b51196eb99e
diff --git a/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2.ebuild b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2.ebuild
new file mode 100644
index 000000000000..ecf80737e6ff
--- /dev/null
+++ b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A hack for test fixtures, needed for hypothesis inside py.test"
+HOMEPAGE="https://github.com/untitaker/pytest-subtesthack/"
+# pypi tarball misses tests
+SRC_URI="https://github.com/untitaker/pytest-subtesthack/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest