summaryrefslogtreecommitdiff
path: root/dev-python/pytest-subtesthack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pytest-subtesthack
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pytest-subtesthack')
-rw-r--r--dev-python/pytest-subtesthack/Manifest3
-rw-r--r--dev-python/pytest-subtesthack/metadata.xml11
-rw-r--r--dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild30
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pytest-subtesthack/Manifest b/dev-python/pytest-subtesthack/Manifest
new file mode 100644
index 000000000000..5b29ab2d37d2
--- /dev/null
+++ b/dev-python/pytest-subtesthack/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-subtesthack-0.1.1.tar.gz 2410 SHA256 9700cc25e9dbe49a2d399b14ea107ab985ee40ebd0d1a7d457b05d15aa9ae632 SHA512 0bf6425b535e65dc7f06f74493d10fbb6451e78a817174638661d7525f39f092f67db8da010228cbd54b400485e71e443118f91ebef660b9c00d2b354062a55f WHIRLPOOL e8e05351eaf140148f5fc6e3023cd564253e62781d69578f330e3393c0dffaa3ee265c457fb9234f066ece28d42280402401abba540f780d5137d79b5f161fdf
+EBUILD pytest-subtesthack-0.1.1.ebuild 806 SHA256 a7122360083125d46174b03676851a657fd6b5ac277c8e0f537215d3e1d1fdda SHA512 1e5e6c65aa77268ae0cc47c8694249f0f9c79fb0b0fd1baaa9bd2f476fcc6cb44b37e692a3c421a61a967454b5c37f6f857d0f8908fc9ce1c75c9d1b462de426 WHIRLPOOL ea917edbdb5ab0e624618880467e126dcef8d724f6e7d4f3499a315d2de3bfb357c1b20ab2a206e9a74174efb70e6766b84aaa05eabf593706a1d8b49f5eef65
+MISC metadata.xml 321 SHA256 3946a00b940a867378593dc8b92fcff877fe0f71d55a4b92230b310430a0cfc7 SHA512 f1c6901c39e0eaaf79917b0699ae5d7dc9a94b15ed2db4ff08f0e3f2bfdaa567e3848474934bb4d8aafe56198536a4ff8f5a6b4379c2238ee20e4a718bfd9a58 WHIRLPOOL 32e1cf62e36ada3ea78c6aa72078a42fdef2c18140358b3afcf0a8c08aa3f7a4ff9450be77811ef5ccf9954963331fed0455e4f1cbc37be676f0205e10f278c9
diff --git a/dev-python/pytest-subtesthack/metadata.xml b/dev-python/pytest-subtesthack/metadata.xml
new file mode 100644
index 000000000000..6979d31debc3
--- /dev/null
+++ b/dev-python/pytest-subtesthack/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-subtesthack</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild
new file mode 100644
index 000000000000..5213ff6241fa
--- /dev/null
+++ b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="A hack for test fixtures, needed for hypothesis inside py.test"
+HOMEPAGE="https://github.com/untitaker/pytest-subtesthack/"
+# pypi tarball misses tests
+SRC_URI="https://github.com/untitaker/pytest-subtesthack/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ distutils_install_for_testing
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}