summaryrefslogtreecommitdiff
path: root/dev-python/pytest-subtesthack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/pytest-subtesthack
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/pytest-subtesthack')
-rw-r--r--dev-python/pytest-subtesthack/Manifest2
-rw-r--r--dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2-r1.ebuild25
-rw-r--r--dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2-r2.ebuild34
3 files changed, 35 insertions, 26 deletions
diff --git a/dev-python/pytest-subtesthack/Manifest b/dev-python/pytest-subtesthack/Manifest
index daf254c2384f..948650b02604 100644
--- a/dev-python/pytest-subtesthack/Manifest
+++ b/dev-python/pytest-subtesthack/Manifest
@@ -1,3 +1,3 @@
DIST pytest-subtesthack-0.1.2.tar.gz 2669 BLAKE2B f1f5a052f9418732de4a97ff438d280d177860439e667e29ff0d0503740e009c88046b5ba859884e5fa9e958ea1be7388d7fc6838c19e44075ab0ef757ee41c7 SHA512 ddb7b0c27f912bec31e58ddc54930e229755df8980d146c861f7f1c766ae742b4f1552117d89638bdbd443f22890262320a56565954ebc6deeae6184f459a5a8
-EBUILD pytest-subtesthack-0.1.2-r1.ebuild 657 BLAKE2B c8eb0c587d8d56c4e2cbb066ce5cdf291f2769b0fe9201827b83ea11ddcb4f0e9607859973609fc2acd2921199d2e55219a72956d47ad09bc41e0b0a77862d4b SHA512 c36410db2a8c7f9fd091df49558df4434ee3bcc7e290e9309465866d9e5426378082ef36ff414b1bbcb17e32bcaf30c9f9d5be53b537ffee22b650d4cb0ba792
+EBUILD pytest-subtesthack-0.1.2-r2.ebuild 709 BLAKE2B b27b30aea55a82a39625b76122c2f4bf0e7c46d6e37e7215b0eb6137332ea6de878f7903f1244780d7847c5c74cf4cc4f81e464daceb5e87f033b752c33d416b SHA512 a8020181f8584450567a34d05136607b916b578b339c8244302ebe46f43d588832a2597a3ab06783283453480724eff5102a7e6c8a2b580b8f34275461c780cb
MISC metadata.xml 414 BLAKE2B 75bea5f93518f1e9b08ed1ad9f772c670bcf565f28b4a67c511fe919513741257fc5917f180ef31ed3e6d43b7986e8e1357ec456f9ddae4603baee1801dd6cc7 SHA512 5b4440d54b4ceb803ba5d9e4ea97fa38b777dbd1af02275f59011f727d9cb166427e8ed63b164b1891f6313349d49d31f4d7762e679439945a6ed4c24add6f46
diff --git a/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2-r1.ebuild b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2-r1.ebuild
deleted file mode 100644
index 40ab8552ca9e..000000000000
--- a/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2-r1.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="A hack for test fixtures, needed for hypothesis inside py.test"
-HOMEPAGE="https://github.com/untitaker/pytest-subtesthack/"
-# pypi tarball misses tests
-SRC_URI="https://github.com/untitaker/pytest-subtesthack/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-DEPEND="
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests --install pytest
diff --git a/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2-r2.ebuild b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2-r2.ebuild
new file mode 100644
index 000000000000..9bff61945a25
--- /dev/null
+++ b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A hack for test fixtures, needed for hypothesis inside py.test"
+HOMEPAGE="
+ https://github.com/untitaker/pytest-subtesthack/
+ https://pypi.org/project/pytest-subtesthack/
+"
+SRC_URI="
+ https://github.com/untitaker/pytest-subtesthack/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest