summaryrefslogtreecommitdiff
path: root/dev-python/pytest-subprocess
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-23 13:24:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-23 13:24:24 +0100
commitcbf055ae8f2fb67e00df9ea122e64a67f930f576 (patch)
treeed9ab83fb918b8bc4fb292f48dbce597be5d33fb /dev-python/pytest-subprocess
parent8702447e13af0a540c01f75bee0416677bced231 (diff)
gentoo auto-resync : 23:06:2023 - 13:24:24
Diffstat (limited to 'dev-python/pytest-subprocess')
-rw-r--r--dev-python/pytest-subprocess/Manifest3
-rw-r--r--dev-python/pytest-subprocess/metadata.xml12
-rw-r--r--dev-python/pytest-subprocess/pytest-subprocess-1.5.0.ebuild42
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pytest-subprocess/Manifest b/dev-python/pytest-subprocess/Manifest
new file mode 100644
index 000000000000..7ead70355cc7
--- /dev/null
+++ b/dev-python/pytest-subprocess/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-subprocess-1.5.0.gh.tar.gz 34771 BLAKE2B b76ab9234ff2ec437ef9679c2e8af6cdc545189c7fd9f832f68c5cad094c80250c5fe1fd6e0da54d7a8c09da30a66f7f097da66f03d169e149186b49e2b72b56 SHA512 8489993cc396d41d127927ab46a43120528dbcb9641e7be03777689af127df29fe618eee3a815e96a0353cc02117dc1af22800d748476c4fe2b76c2246229f08
+EBUILD pytest-subprocess-1.5.0.ebuild 897 BLAKE2B 90b0857855327a1e43c27530641ca93c75b44a21500b89559ce8ab6b4c3cb1f78c346f9dee561b4c51a70f2f56c6a456f9eea2b5638c40b50c405840d59bb142 SHA512 85121699db7cafc93a1dcc50272723e37744d4dff717fee3108b0005e5adc235967222512ffbf66314a8c7d921ec3f7dd8cc468059930bd8e8b7a684751cdeac
+MISC metadata.xml 390 BLAKE2B a3bc770c204c31105ed2d53ab7ff74679fa2738e4cb422a17157e88c7f1bdc061af21e238fb63fcf32982ba3b60fd7ea51678dd594ec03befc1d41db48663004 SHA512 664188e01242f89a25192355de77622ddf6d1448a65f665515a7294754f0bae30dfa63baa03104759d93e9c1800471fa579ee11b8fe4ce1229cce400fffe9f89
diff --git a/dev-python/pytest-subprocess/metadata.xml b/dev-python/pytest-subprocess/metadata.xml
new file mode 100644
index 000000000000..fff3884af1d5
--- /dev/null
+++ b/dev-python/pytest-subprocess/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">aklajnert/pytest-subprocess</remote-id>
+ <remote-id type="pypi">pytest-subprocess</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-subprocess/pytest-subprocess-1.5.0.ebuild b/dev-python/pytest-subprocess/pytest-subprocess-1.5.0.ebuild
new file mode 100644
index 000000000000..bb2a21146b87
--- /dev/null
+++ b/dev-python/pytest-subprocess/pytest-subprocess-1.5.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A plugin to fake subprocess for pytest"
+HOMEPAGE="
+ https://github.com/aklajnert/pytest-subprocess/
+ https://pypi.org/project/pytest-subprocess/
+"
+SRC_URI="
+ https://github.com/aklajnert/pytest-subprocess/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pytest-4.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/anyio[${PYTHON_USEDEP}]
+ >=dev-python/docutils-0.12[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.15.1[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:flaky
+}