summaryrefslogtreecommitdiff
path: root/dev-python/pytest-skip-markers/pytest-skip-markers-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-21 09:59:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-21 09:59:48 +0100
commit54c57c0355214cac06d4618d5f9d4b1ae9aeaac3 (patch)
tree43735a7fec07f4d0069579eb33e71aff2b885e83 /dev-python/pytest-skip-markers/pytest-skip-markers-1.5.0.ebuild
parent206ec2c4ffbadc599d05d0abde0ca644856bbf68 (diff)
gentoo auto-resync : 21:10:2023 - 09:59:47
Diffstat (limited to 'dev-python/pytest-skip-markers/pytest-skip-markers-1.5.0.ebuild')
-rw-r--r--dev-python/pytest-skip-markers/pytest-skip-markers-1.5.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pytest-skip-markers/pytest-skip-markers-1.5.0.ebuild b/dev-python/pytest-skip-markers/pytest-skip-markers-1.5.0.ebuild
new file mode 100644
index 000000000000..1ede21a80147
--- /dev/null
+++ b/dev-python/pytest-skip-markers/pytest-skip-markers-1.5.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Pytest plugin which implements a few useful skip markers"
+HOMEPAGE="
+ https://pytest-skip-markers.readthedocs.io/en/latest/
+ https://github.com/saltstack/pytest-skip-markers
+"
+SRC_URI="
+ https://github.com/saltstack/pytest-skip-markers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7.1.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytestskipmarkers.plugin,pyfakefs.pytest_plugin
+ epytest
+}