summaryrefslogtreecommitdiff
path: root/dev-python/pytest-shutil/pytest-shutil-1.7.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /dev-python/pytest-shutil/pytest-shutil-1.7.0-r2.ebuild
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'dev-python/pytest-shutil/pytest-shutil-1.7.0-r2.ebuild')
-rw-r--r--dev-python/pytest-shutil/pytest-shutil-1.7.0-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pytest-shutil/pytest-shutil-1.7.0-r2.ebuild b/dev-python/pytest-shutil/pytest-shutil-1.7.0-r2.ebuild
new file mode 100644
index 000000000000..8ee1fa7aea61
--- /dev/null
+++ b/dev-python/pytest-shutil/pytest-shutil-1.7.0-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A goodie-bag of unix shell and environment tools for py.test"
+HOMEPAGE="https://github.com/man-group/pytest-plugins https://pypi.org/project/pytest-shutil/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+"
+# block pytest plugins that will be broken by the upgrade
+RDEPEND+="
+ !<dev-python/pytest-virtualenv-1.7.0-r1[python_targets_python2_7(-)]
+"
+
+BDEPEND="
+ ${RDEPEND}
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ # remove unnecessary deps
+ # (contextlib2 is not used in py3)
+ sed -i -e '/path\.py/d' -e '/contextlib2/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}