summaryrefslogtreecommitdiff
path: root/dev-python/pytest-shell-utilities
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-29 15:07:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-29 15:07:44 +0100
commitc9ac6938788ee1708e7c900f8f78e9037aea1ca1 (patch)
tree7775fcc8916726b2e7a58d7a251dee69292d231f /dev-python/pytest-shell-utilities
parent23fb10c075a74a6504647a16c3e06a6378e208c8 (diff)
gentoo auto-resync : 29:07:2022 - 15:07:44
Diffstat (limited to 'dev-python/pytest-shell-utilities')
-rw-r--r--dev-python/pytest-shell-utilities/Manifest2
-rw-r--r--dev-python/pytest-shell-utilities/pytest-shell-utilities-1.6.0.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pytest-shell-utilities/Manifest b/dev-python/pytest-shell-utilities/Manifest
index 78be39522a89..e25c449f6613 100644
--- a/dev-python/pytest-shell-utilities/Manifest
+++ b/dev-python/pytest-shell-utilities/Manifest
@@ -1,3 +1,5 @@
DIST pytest-shell-utilities-1.5.0.gh.tar.gz 92287 BLAKE2B 015f78838eaff93438cbd7cd395926ac8f61653f6d27275ca87b379e5f27d60165157880e41e603823c17e639dcff91ac4f5fda1e904ad505bb9db0a577b800c SHA512 00cb5fa6979e09c90ba82928a135f644dd4056fd004f6bee8d216ca63e2cf4549f944930bf16e7a124f26a79c1b696d18ecf210bee3273343b9a90f9126f340e
+DIST pytest-shell-utilities-1.6.0.gh.tar.gz 92343 BLAKE2B 39239aff1d7d4970a706926ea9f4c7808f8c12760d8f1ccaff760d8320024bba7373a25bb2ad8db2e0a6fee1f8ef4dd5b85b4e7eb1fb6e2aab64711686acf25e SHA512 e979f5bbf34de99c1dac33b4cb27265a210852d39792cd7660b717e43de0baaf47785d57ade226f08de43ef9d83600b4e46f70ceed341c7fccde554f7a838b8e
EBUILD pytest-shell-utilities-1.5.0.ebuild 1059 BLAKE2B f952a1730a3315233009193fb9a1d480bf5067a0d6b1a65facd6e2abb936486a8f4e756d828e7c90543a2ef6481e039e960f32d8c545f0ddf83e69d8c152e77a SHA512 3839b6e62221d30f0386d2b70c87d61c1f21865b0236195e653230b11ba47f97624376d7b64f0b8b2ae5c6ade347a7f71015e9e11a3bd9d417d0a62e4ee0bd05
+EBUILD pytest-shell-utilities-1.6.0.ebuild 1061 BLAKE2B c68a5f83c1e58dd6f621b3c9e6b785aba71dfb1a1a4305183434b3a568577ddfd1012be6d7ce2e3a483e1b523eadd8c07ee60e12731adcddf72b875d4de13508 SHA512 bc28ee81b3da0beff6baf0c4d7e6f6619c571267a0b2d1ba057e5ddc769a4a921683444f9b5678ff863a04a7fce3a8a0a2ee970ff94472fc3b2364b84ea023f1
MISC metadata.xml 436 BLAKE2B 8cb927224ae6ac36a59818b60f8b4ef4a8d1cc4ca284934f50fbcc957ac25a417307c533d6d3728f38e98977ace3cdb106b9b62abe10a9b843a42ecdb30c97e4 SHA512 505a9f97a74581b9c7f59862186db14ab2f543cadbd05424e32541f31ff0c88295b4ed0b6dfbfa53dec1208d16275fcf99cc72c6a51c95e7f07e5392804a09cd
diff --git a/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.6.0.ebuild b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.6.0.ebuild
new file mode 100644
index 000000000000..84d66d2dc910
--- /dev/null
+++ b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.6.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin: fixtures and code to help with running shell commands on tests"
+HOMEPAGE="
+ https://pypi.org/project/pytest-shell-utilities/
+ https://github.com/saltstack/pytest-shell-utilities/
+"
+SRC_URI="
+ https://github.com/saltstack/pytest-shell-utilities/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}