summaryrefslogtreecommitdiff
path: root/dev-python/pytest-services
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/pytest-services
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/pytest-services')
-rw-r--r--dev-python/pytest-services/Manifest2
-rw-r--r--dev-python/pytest-services/pytest-services-2.2.1-r1.ebuild (renamed from dev-python/pytest-services/pytest-services-2.2.1.ebuild)28
2 files changed, 15 insertions, 15 deletions
diff --git a/dev-python/pytest-services/Manifest b/dev-python/pytest-services/Manifest
index 8d72bc579b94..29b642b2bd26 100644
--- a/dev-python/pytest-services/Manifest
+++ b/dev-python/pytest-services/Manifest
@@ -1,5 +1,5 @@
AUX pytest-services-2.0.1-lockdir.patch 1085 BLAKE2B 09982cf4874d82a332b441e4538d1fb177735af3acb2ba2d7fed9c0a2ef006841ca0c4221fc51c0472a0a94c49bbcb72877c67b5c7630333f550e3fda1b5aa91 SHA512 7b5d4d5adb722936bd3593ed4e12fa2ca9bc3aa764565d9cbbea2d70424d9811d5838e97bbbe8fafa2f73acb8bdfa6c705e8c4aec12b5b6556b1e4c8db629ea9
AUX pytest-services-2.0.1-no-mysql.patch 821 BLAKE2B 3a041e51c0e2c08ce8727eccdbfac36eacec2542d8d8cc7ab7544f46916b47a62e960437821f8fa85fe968b9e68808b94d9ac51fe06daf487008bfaf305ba81e SHA512 68788f6b6700793df2de4fbae85a41fad095f09ac9af717c786305fc1ca6b29438a65d096076b9469dc543a54ce8f72a40dc0f211eb9d517e658ce068e60ee23
DIST pytest-services-2.2.1.tar.gz 21303 BLAKE2B 6f4b66b713ca4976eae61bf516bfecf13b8d6f56e03ae772ba9465e7c4c52b8d5ffa713b9441c73538a0b05665da7b7aa53d5f5da1626c6c208edf1c8239b1b1 SHA512 95d70431a7c3fa3b1602e6ad0e72975cecf5f0464e1bbc21d5b4eee6aefee52794c7b1d8dacf0681cc4cbb5ae7910075a7d0b3859647cc55298a2792489c4bfb
-EBUILD pytest-services-2.2.1.ebuild 1206 BLAKE2B 6201c98783409c49e60e3daa8ff3fae828ba4734072676547c5180a72aadbbd55515c9a417452ad74eb8ffd48c8d22bea9acd0dd2778126d57da281ad7af5291 SHA512 cafe8b1a9f537b19cf759e201b355a349da457deaf0761ff4eb0db2616cc88e77da79d48c9413eebeac894c3e83cdba73126b7fa0f891e5330b63af04a97963c
+EBUILD pytest-services-2.2.1-r1.ebuild 1119 BLAKE2B 197aade6ee13f5ed34b8bc526a37e55fcf03805a04492cf9fff53f2941654c7979a36bc9768eed0b760132d31869f43d7b2681d8a5afc84516b863cb3eb41012 SHA512 6ba554d706311dc89479bf667592a2ed81d4d6c6aee23ed7ff075a472cb1036e440858a6142faaa889f52bab257cdb74ddf6a515b3464ecef7f2f91b642cc611
MISC metadata.xml 409 BLAKE2B 9404f6ceb2072dddeb6dee14b62e76bfe75c0123c352feea87c5ef43793efa7ce778203fe44727ba56dbf21b408fef027a479f66c3f5542b71e140aeac5624eb SHA512 3dd74088fbe606f8188e121dc76a269ebcc1ed7cebeb6a3ad9fe153c9f1097b468aae12a1e86ce4c1a8a6c7a10136b8a9889e2a96dfd9f0fe252440e3edae1c8
diff --git a/dev-python/pytest-services/pytest-services-2.2.1.ebuild b/dev-python/pytest-services/pytest-services-2.2.1-r1.ebuild
index 67efd3025477..f44d7562aadf 100644
--- a/dev-python/pytest-services/pytest-services-2.2.1.ebuild
+++ b/dev-python/pytest-services/pytest-services-2.2.1-r1.ebuild
@@ -3,17 +3,24 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
inherit distutils-r1
DESCRIPTION="Collection of fixtures and utility functions to run service processes for pytest"
-HOMEPAGE="https://github.com/pytest-dev/pytest-services"
-SRC_URI="https://github.com/pytest-dev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-services/
+ https://pypi.org/project/pytest-services/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-services/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ~ppc64 ~riscv x86"
-IUSE="test"
RDEPEND="
dev-python/requests[${PYTHON_USEDEP}]
@@ -22,7 +29,7 @@ RDEPEND="
dev-python/zc-lockfile[${PYTHON_USEDEP}]
"
BDEPEND="
- test? ( ${RDEPEND}
+ test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pylibmc[${PYTHON_USEDEP}]
x11-base/xorg-server[xvfb]
@@ -31,7 +38,7 @@ BDEPEND="
)
"
-RESTRICT="!test? ( test )"
+distutils_enable_tests pytest
PATCHES=(
"${FILESDIR}/pytest-services-2.0.1-no-mysql.patch"
@@ -39,12 +46,5 @@ PATCHES=(
)
python_test() {
- distutils_install_for_testing
- pytest -vv tests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install
-
- find "${D}" -name '*.pth' -delete || die
+ epytest -p no:xvfb
}