summaryrefslogtreecommitdiff
path: root/dev-python/pytest-salt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
commit6d691ad5b6239929063441bbd14c489e92e7396e (patch)
treee294f87b1ce66397fee1273bd6c7131aeb586f51 /dev-python/pytest-salt
parentd99093fb4bb5652015c06274d64083daa2439e4f (diff)
gentoo resync : 05.03.2021
Diffstat (limited to 'dev-python/pytest-salt')
-rw-r--r--dev-python/pytest-salt/Manifest3
-rw-r--r--dev-python/pytest-salt/files/pytest-salt-2020.1.27-r2.patch14
-rw-r--r--dev-python/pytest-salt/pytest-salt-2020.1.27-r2.ebuild (renamed from dev-python/pytest-salt/pytest-salt-2020.1.27-r1.ebuild)4
3 files changed, 20 insertions, 1 deletions
diff --git a/dev-python/pytest-salt/Manifest b/dev-python/pytest-salt/Manifest
index 20143a8d3525..3af29bb378a0 100644
--- a/dev-python/pytest-salt/Manifest
+++ b/dev-python/pytest-salt/Manifest
@@ -1,3 +1,4 @@
+AUX pytest-salt-2020.1.27-r2.patch 744 BLAKE2B 43eadb0fb01406efb9e67388a6b0ca5a021ae6ec622ec5dd5dfb1ab9575489c711dc805ce64e1373e4a0044490d71132ff4eb9584f3e9f2fb043a168d18d8349 SHA512 b0a0d56dc7d5ab43a1970488128c97de5f2c266523889896cab53040cb8eb426bda88cd8d641d706b6d09fbaf1b3f439cbfe947264cc004e766e6cc84350076f
DIST pytest-salt-2020.1.27.tar.gz 64141 BLAKE2B 2b9261af2de28f8dce1abcd71b586594075916c8a5dbb27a24f15b9d95a575624be118d1c742f02020d3b968ffa4654cf6cd0dabefffe6876b87a4d1d58c3d60 SHA512 b0632e21f1ea5c3b57eb681cd8b270721cafd270321b708fca65427fc89817ed9e9a4216a520f35988c6866b1ed76ed84838009da9052a11cf8782d4dcf118ba
-EBUILD pytest-salt-2020.1.27-r1.ebuild 932 BLAKE2B c91d9cd7550e2851495bd62f23cbdec4a6478ee3e9b9e7fc1bd7a9ad9164434ffb68c61eadb03652f908096042c976bd9c4892a5da5fedf9c34a7fb4006d2f88 SHA512 927ad629be37d60d94490c6ad0a1c9d190f1661464a55884376b047e33d3978e69f1dd6f865605695434c226587f436c923a8acd8260d4191b703c8dfcb651f2
+EBUILD pytest-salt-2020.1.27-r2.ebuild 985 BLAKE2B 481b1562789969656c0f97ffb19bed526af1190e55adcf31ad257de8f27bafc9116da616b44a334e17cd8030e99c4fa9e15474450fc318509f7d876f2384cc1d SHA512 bff1f3f05ad4bdbe1578a34d3c6c6fefbb02bcb02f5f93b86a6fa5461adac2df345db492a6be4f10f37ee572173dafb09ac650621ea52e9b56d7e88feceef0de
MISC metadata.xml 323 BLAKE2B 2eede80f9d146aa2dc511191d1e1ef7a689786878c2ba77ee62dc181d49ed07475f657886e6f9d662140ff378ddeaf65f979a6e483b92ff97834e934b225b430 SHA512 ca8b7955dc3025e3ed15ef0556b02a80b033dc2003bbb3030b42112e04d1945436a3ff2224bd2149ec34210d50a66fcc0b1577dd1464fc8e1e4ed097286e02a1
diff --git a/dev-python/pytest-salt/files/pytest-salt-2020.1.27-r2.patch b/dev-python/pytest-salt/files/pytest-salt-2020.1.27-r2.patch
new file mode 100644
index 000000000000..35dca262478b
--- /dev/null
+++ b/dev-python/pytest-salt/files/pytest-salt-2020.1.27-r2.patch
@@ -0,0 +1,14 @@
+Fixes a Doctestitem has no attribute 'fixturenames'
+Fix by David Denoncin based on https://github.com/saltstack/pytest-salt/issues/48
+
+--- a/pytestsalt/fixtures/daemons.py 2021-03-02 15:19:40.500254583 +0100
++++ b/pytestsalt/fixtures/daemons.py 2021-03-02 15:20:40.706920871 +0100
+@@ -1658,7 +1658,6 @@
+ Fixtures injection based on markers
+ '''
+ for fixture in ('salt_master', 'salt_minion', 'salt_call', 'salt', 'salt_key', 'salt_run'):
+- if fixture in item.fixturenames:
+- after_start_fixture = '{}_after_start'.format(fixture)
++ if fixture in getattr(item, 'fixturenames', ()):
+ if after_start_fixture not in item.fixturenames:
+ item.fixturenames.append(after_start_fixture)
diff --git a/dev-python/pytest-salt/pytest-salt-2020.1.27-r1.ebuild b/dev-python/pytest-salt/pytest-salt-2020.1.27-r2.ebuild
index 65b1f4a6405d..f3d2b483cbdb 100644
--- a/dev-python/pytest-salt/pytest-salt-2020.1.27-r1.ebuild
+++ b/dev-python/pytest-salt/pytest-salt-2020.1.27-r2.ebuild
@@ -28,6 +28,10 @@ RDEPEND="
# test? ( app-admin/salt[${PYTHON_USEDEP}] )
#"
+PATCHES=(
+ "${FILESDIR}/${PN}-2020.1.27-r2.patch"
+)
+
# tests need network access
RESTRICT="test"