summaryrefslogtreecommitdiff
path: root/dev-python/pytest-rerunfailures
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-23 05:24:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-23 05:24:22 +0000
commitfdbd219bffd44c5fa62c89f7dc329673445ee026 (patch)
tree0e37bcfa502fe395603052eee0483ff956d10ddd /dev-python/pytest-rerunfailures
parent40d8bc05c536b6c3fa0bd58c50480dc79c6b9e92 (diff)
gentoo auto-resync : 23:11:2023 - 05:24:22
Diffstat (limited to 'dev-python/pytest-rerunfailures')
-rw-r--r--dev-python/pytest-rerunfailures/Manifest2
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-13.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-rerunfailures/Manifest b/dev-python/pytest-rerunfailures/Manifest
index 0a95e7c35ca2..3de5c427eab6 100644
--- a/dev-python/pytest-rerunfailures/Manifest
+++ b/dev-python/pytest-rerunfailures/Manifest
@@ -1,3 +1,5 @@
DIST pytest-rerunfailures-12.0.tar.gz 21154 BLAKE2B 3de39a8b92858bd90b312fca1c5f2e5ad790e12277f118bf18182b6192edf14dd160070bfe31ce981dc7ba41e0d0e2509ea80793c35c1856afdcfb5272ca55cc SHA512 2e6787ec8b420344eb1f7175b0f9e7f8a2f3cc3fd59ebf0c49128b39dc887200bd497e1d73a59311d072456e34126a1829324a4d86f86e5c01916940383c8fd4
+DIST pytest-rerunfailures-13.0.tar.gz 20846 BLAKE2B 7fbe5b05091ec358769837cb5a3f505f2901e4cec71f311268c606b237b25199d3dddb86f81399c8222f582570d99ef12a51d020d9610ea7fe25aca0a79294fe SHA512 466da7beac4785c82362e65c2c3420a5ac7c3d52a2b0c00f67ab6b8a5c64a51fc0b2172e7308c072b28a0cb0f74e1178f94ade3b10f4ad929ddf33057c80a654
EBUILD pytest-rerunfailures-12.0.ebuild 777 BLAKE2B 08d7a0bb5c1a3f17d8ca620f7cb93781cccf616bd2113604aa3ab18825749deb19f911017bcd4699e4ddbfa4bd732645506a56c1690093b5ae00b4fa42658795 SHA512 699bd22262f7431b57ffd880e7747b21af2901f9779695344b129bc0b8c965c372b764fbeb42d0eaedc43b93a9ae3017369fe9fd036f24293d8e493502479706
+EBUILD pytest-rerunfailures-13.0.ebuild 785 BLAKE2B 83a9cfd8eb22d8d3465b13bbcbfae5b65fb650bc61cb7fc1d1d763199773b6cf977adce7026ef3eac1e8a022a8dcab4833601aa21f81881e3830bcd9028ce5fe SHA512 1082bd4de1fd1ba38da553f8bc0d96fd9ed5a5f003e620ef1b0ac88445b7331b813c0a81855c1f2f8ed48135a816f1398917122738a2464cecb2bf9ac645fd23
MISC metadata.xml 432 BLAKE2B 3bbb0bd303a26d2a336563f187160b3b023e6d7a3a776922dee4853164d7461f395e840b2c0ba1349687d24050ccb5fd18166aeec397c9b21a1aa0e6b536b795 SHA512 f372a1f73a4dc3e60f66bd6049cddb4d8cd8fe53bebff2a6d194eb3d5872adab9b7ac226971696fb24a8d4e4744427c4d4148054fc51a94f63320d428ef80d52
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-13.0.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-13.0.ebuild
new file mode 100644
index 000000000000..c6263b8ee63e
--- /dev/null
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-13.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin to re-run tests to eliminate flaky failures"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-rerunfailures/
+ https://pypi.org/project/pytest-rerunfailures/
+"
+
+SLOT="0"
+LICENSE="MPL-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/packaging-17.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_rerunfailures
+ epytest
+}