summaryrefslogtreecommitdiff
path: root/dev-python/pytest-rerunfailures
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-21 03:03:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-21 03:03:00 +0000
commit9db1279f804d62da2c61cfb39fc2e62b9faf56dd (patch)
tree7b951d5bf3ab775b91a18e0022d8f19d3582d84e /dev-python/pytest-rerunfailures
parent8a5f3383bbc5f817d89554020a3600d06985bc4a (diff)
gentoo auto-resync : 21:11:2024 - 03:03:00
Diffstat (limited to 'dev-python/pytest-rerunfailures')
-rw-r--r--dev-python/pytest-rerunfailures/Manifest2
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-15.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-rerunfailures/Manifest b/dev-python/pytest-rerunfailures/Manifest
index 480deaf34003..325398abfd20 100644
--- a/dev-python/pytest-rerunfailures/Manifest
+++ b/dev-python/pytest-rerunfailures/Manifest
@@ -1,3 +1,5 @@
DIST pytest-rerunfailures-14.0.tar.gz 21350 BLAKE2B bb273d77a732c0296ca041b4cbd91fd48052076e9f76839b862b03de9f448208a216483bc486f23542cd99a12ef2934a46e3ea4162ca87bfd5c0904f2d114179 SHA512 8aa23a57206b0e6af133c716517c3c96cc156cc2f86b06c0fa80e9fea2b11f32e98cfb41f6a5fb05b38bab7496258160ba42fe6ae00d7bef8024159a8ed4a3f5
+DIST pytest-rerunfailures-15.0.tar.gz 21816 BLAKE2B 75c42cec3a9cc0208e045be82c1b6660d56fff898ac0e97e992a020229a095a619eb1e87eeca8af7fba4f455f044ddd9729943becd90d185356e7bddb9ab1c6b SHA512 c03f430f9e24e0b149391e08ae6f38450d731d1f6a28294173e75f8776dc596230422e2082bbbc74cf31ea7e4c3105f5d8d57825dc418c4ce1c5538d84c861c3
EBUILD pytest-rerunfailures-14.0.ebuild 1373 BLAKE2B 07c44b649a1070cab20868d738ea8e4c9b6c1c9f9bae98bfef0afe099a35c460026b1fc607637bf1788133e58947323a53ad4fbf04643414a52c85c88b903a68 SHA512 21f86f18e5e78f12effe3ef51042c285971d4bd95f6ef589274bb6d1b83e1f82a15ecb9e0c36aba429262fd0b75a529cf4ee107322ccb95ac0ddf24da7fe0ab7
+EBUILD pytest-rerunfailures-15.0.ebuild 779 BLAKE2B ca919e4d8dd3f369c1de26c27258014f2ef9a08cf79fd5e580e984719741edb9cb5ed54cb58aed4bc7c296c9d6418dc32f699b9a944ce29dfb341a2dc9def4a3 SHA512 b7f0d504c320452fb464b86eb04f65f76d382b0d7d767bd3eae6e5591ea634ba9f391d32dd8899a283c79e6f569dcef3988aa5edc6c0125f703e522159ca71a9
MISC metadata.xml 432 BLAKE2B 3bbb0bd303a26d2a336563f187160b3b023e6d7a3a776922dee4853164d7461f395e840b2c0ba1349687d24050ccb5fd18166aeec397c9b21a1aa0e6b536b795 SHA512 f372a1f73a4dc3e60f66bd6049cddb4d8cd8fe53bebff2a6d194eb3d5872adab9b7ac226971696fb24a8d4e4744427c4d4148054fc51a94f63320d428ef80d52
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-15.0.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-15.0.ebuild
new file mode 100644
index 000000000000..74f5be166cc3
--- /dev/null
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-15.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin to re-run tests to eliminate flaky failures"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-rerunfailures/
+ https://pypi.org/project/pytest-rerunfailures/
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/packaging-17.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_rerunfailures
+ epytest
+}