summaryrefslogtreecommitdiff
path: root/dev-python/pytest-rerunfailures
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-23 13:08:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-23 13:08:35 +0000
commit87cdf8e64e5874146493d2a4a4489b08583043c3 (patch)
treeb481dca3db38189f893c7e9fdf3fb98731b097a9 /dev-python/pytest-rerunfailures
parentbed152ba1fc2f1316eaefb5c3d24d48195560f76 (diff)
gentoo auto-resync : 23:11:2022 - 13:08:35
Diffstat (limited to 'dev-python/pytest-rerunfailures')
-rw-r--r--dev-python/pytest-rerunfailures/Manifest2
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-10.3.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-rerunfailures/Manifest b/dev-python/pytest-rerunfailures/Manifest
index ee2998e29651..62491ec023a3 100644
--- a/dev-python/pytest-rerunfailures/Manifest
+++ b/dev-python/pytest-rerunfailures/Manifest
@@ -1,3 +1,5 @@
DIST pytest-rerunfailures-10.2.tar.gz 15863 BLAKE2B 9f317f3a39ac234e145a14d532d2727bb9fb5fead65c05372cf95268e0f589f9de994cd3c47e75dcb354c996595698c43fccdea5134d2e1921429c8ea7b71451 SHA512 8830610276e2cc172ee372ae4d8376bc6329138751ea2737a4def6af32d05c112c872a7a180ff554018058c05ed0d109927dbac61f748586257e40b0243f03c8
+DIST pytest-rerunfailures-10.3.tar.gz 15852 BLAKE2B 1063f55f4145eff4db22f121620cb3a53ad8cd0c44580578bd5027c4bd8005af6d33e0da8d67fceb7b8abe91f22c591e7b42b7a810cb5c7d8b5668b0a48eb3f2 SHA512 30ebafdb221d7ff8c46d50795b1a342b55293eaf60f5a012c631e2333dcf3114bfc4ed5210705edba4ad33a8f215ce7b5988362750149fc5e9463e4c3fa93860
EBUILD pytest-rerunfailures-10.2-r1.ebuild 899 BLAKE2B 523b954d54f811a155b4b63232c76f2da365f2409e391fb50b831e38c680276396f6d4f4d0c6425a5808c2b875230fbe8bcca19790b1f5537faeddbfbd7ec2de SHA512 45347b510fac16dd65b82feee2ae6a81f7acbce40ae108d570431030cfbdbbfd71b500564177cb298d8b5053186b25e788226463e5cddb1fb019a10641723342
+EBUILD pytest-rerunfailures-10.3.ebuild 811 BLAKE2B d10386cf0bd51587ee62ca9946bc9b034b3edb2c82fa4d84e0648fa1c5974754848aacf0a45c569879464083f05253315f4643cd53283a497ef5af9dd69001ef SHA512 7449a3b2ba68a36a937a0da17f82987210214b9ee4de548995e33a80cf5d0f424368626735b5c496d0c68d493ab00dd81cc861285739b73fb161743e8a42f2b6
MISC metadata.xml 432 BLAKE2B 3bbb0bd303a26d2a336563f187160b3b023e6d7a3a776922dee4853164d7461f395e840b2c0ba1349687d24050ccb5fd18166aeec397c9b21a1aa0e6b536b795 SHA512 f372a1f73a4dc3e60f66bd6049cddb4d8cd8fe53bebff2a6d194eb3d5872adab9b7ac226971696fb24a8d4e4744427c4d4148054fc51a94f63320d428ef80d52
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.3.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.3.ebuild
new file mode 100644
index 000000000000..db19fb8cb3d3
--- /dev/null
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to re-run tests to eliminate flaky failures"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-rerunfailures/
+ https://pypi.org/project/pytest-rerunfailures/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MPL-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/packaging-17.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_rerunfailures
+ epytest
+}