summaryrefslogtreecommitdiff
path: root/dev-python/pytest-rerunfailures
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/pytest-rerunfailures
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/pytest-rerunfailures')
-rw-r--r--dev-python/pytest-rerunfailures/Manifest3
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2-r1.ebuild35
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild2
3 files changed, 38 insertions, 2 deletions
diff --git a/dev-python/pytest-rerunfailures/Manifest b/dev-python/pytest-rerunfailures/Manifest
index d9e826c4faf0..35e4619cbb3b 100644
--- a/dev-python/pytest-rerunfailures/Manifest
+++ b/dev-python/pytest-rerunfailures/Manifest
@@ -1,3 +1,4 @@
DIST pytest-rerunfailures-10.2.tar.gz 15863 BLAKE2B 9f317f3a39ac234e145a14d532d2727bb9fb5fead65c05372cf95268e0f589f9de994cd3c47e75dcb354c996595698c43fccdea5134d2e1921429c8ea7b71451 SHA512 8830610276e2cc172ee372ae4d8376bc6329138751ea2737a4def6af32d05c112c872a7a180ff554018058c05ed0d109927dbac61f748586257e40b0243f03c8
-EBUILD pytest-rerunfailures-10.2.ebuild 838 BLAKE2B 08334775c8f53286eae0a253cbf11850b83c994887340d07751727c0e2aae08e95e978a96c34252b7b0a8780464e8e360104f731a320e5de3c0e6777e9334a40 SHA512 b022b7a9014d6981fced09cfdb4d8a6d8b3473f0475a901427a90cc391391b10952426eb303880c54fe46602473715d5dac5c879274b918a629d8ab29bb454aa
+EBUILD pytest-rerunfailures-10.2-r1.ebuild 907 BLAKE2B bfcaf8abb5ad3ac825bc6937a1a0cd6ecceda311f3291095b5f2024f498eca74f9ab994f339fc2153f2fa02af0cff76362cde4dbce6b2c7a31363e034333fbee SHA512 e26c959b1c58ec06220e814b6a7fba04b4e6d12ed86e2ba10425080a5378db287e54e2c7320cd9fa053d0c1a40e824d4e00cd9ede1e5d3e21893b4a7755020c9
+EBUILD pytest-rerunfailures-10.2.ebuild 845 BLAKE2B 59adf88ddab0bf066213e4f8a7613044fd077c76f8800ebdb5fa1c1b6cc2743b16950fdf643e643aacadb1f4cceb7797f1a323fc31ee2ec3b7ebdc9ff42be1bf SHA512 675ac1ad11f81cde29e8025135fecd93ac432398dbd642f83f88ae5b805f6700cd4eb13af3bb6f1f2df4cf609db9dac995bf84014b100a304f65301105e87e54
MISC metadata.xml 432 BLAKE2B 3bbb0bd303a26d2a336563f187160b3b023e6d7a3a776922dee4853164d7461f395e840b2c0ba1349687d24050ccb5fd18166aeec397c9b21a1aa0e6b536b795 SHA512 f372a1f73a4dc3e60f66bd6049cddb4d8cd8fe53bebff2a6d194eb3d5872adab9b7ac226971696fb24a8d4e4744427c4d4148054fc51a94f63320d428ef80d52
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2-r1.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2-r1.ebuild
new file mode 100644
index 000000000000..f95ab9e36356
--- /dev/null
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to re-run tests to eliminate flaky failures"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-rerunfailures/
+ https://pypi.org/project/pytest-rerunfailures/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MPL-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_rerunfailures
+ if has_version "dev-python/pytest-xdist[${PYTHON_USEDEP}]"; then
+ PYTEST_PLUGINS+=,xdist.plugin
+ fi
+ epytest
+}
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild
index 9bb95d7201ad..4079a3b88a38 100644
--- a/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="MPL-2.0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
BDEPEND="
>=dev-python/pytest-5.0[${PYTHON_USEDEP}]