summaryrefslogtreecommitdiff
path: root/dev-python/pytest-relaxed
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /dev-python/pytest-relaxed
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'dev-python/pytest-relaxed')
-rw-r--r--dev-python/pytest-relaxed/Manifest3
-rw-r--r--dev-python/pytest-relaxed/files/pytest-relaxed-1.1.4-no-autoload.patch12
-rw-r--r--dev-python/pytest-relaxed/pytest-relaxed-1.1.4.ebuild35
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pytest-relaxed/Manifest b/dev-python/pytest-relaxed/Manifest
index ab7216059e34..1176d5f81ed8 100644
--- a/dev-python/pytest-relaxed/Manifest
+++ b/dev-python/pytest-relaxed/Manifest
@@ -1,3 +1,6 @@
+AUX pytest-relaxed-1.1.4-no-autoload.patch 391 BLAKE2B f4d7e9eb5449bb22e3056136ab2c9baf1ac281c9f400345fe9cf794c16200279113528cdae7911f559f9c771e78b7ada354985fb1945aac96c1b1cc3807515e8 SHA512 27f45f5b6a6649305f2a1be67277d70b9fc9de4e1ad937ad7e9be3775184167838d9daf518a1967b4069c6133cfa858e768f9a70b6f1a73486f3f32e6c98ce2b
DIST pytest-relaxed-1.1.0.tar.gz 25942 BLAKE2B 6dd34044ec3ae0b5c85f0a76102aaeafe3dad8748c0cf34666dd3550162a2968191efb8415467259a4f072905af062aeabaaaeb475ab68d47aa8d79e3cadd3d0 SHA512 010e37c4d0c63bd00af8851bb50e52af7f8f17769be042e4941e8d8ba451920c24dfa6cdf74cd1b3ca4b3e1c71cd5e1ac34ffae855fc261cf431c212f98cbfff
+DIST pytest-relaxed-1.1.4.tar.gz 26854 BLAKE2B c9b4d7c5c68fb24deaa9b107960eec7b24ab1cfe4ed37f0ffa99b4e5a9d3572be860ff3bc39882f5024fb6aad73f5f976c450294cf713483bba655af56b70245 SHA512 d4e7ed5143ac9f1bff1f911e4ab3aede076d154dcecc28ce96cbc49782d186214893b942a3548da2789faa51df5ddbd43ff41c82b9bb9d0d52f38a2000fc0c6b
EBUILD pytest-relaxed-1.1.0.ebuild 918 BLAKE2B 1e395bebaf4838cb8e5dfb395693492ed42bd898a727ac1b83098fa1fb374e71d4c4ddf4dfd0b3a225e0b69042f206fb28cae2d5697a8c40f08c9d9bc3be32e7 SHA512 14d7160ee46b35cecd9cdc6184f9a8abdc55e0588d05462189e14b84e87161c95bfabb9854342b597b24c074dcc778e11552843850fafd4e93bc05d00e7848a5
+EBUILD pytest-relaxed-1.1.4.ebuild 1192 BLAKE2B 28b346c01c2eeb62de158bf797390c3ca983af69e5d5ce56ed87a68fa798d2cff6872064f6a9274d5092fe13a70dce45dd0dcd3595ed552dc6ccfb79dbfc3116 SHA512 ba3843d927157827d6282da930a75892d952b0bbc5aeff97a558ffc85b134f409c33a597ec9abe064c2583f09bc4d2569107df221c6d1397c47877f072c4d6dc
MISC metadata.xml 382 BLAKE2B 858b2e05190a45c6842f93638cc598f3b97b3481a361438789a2f1e4aabfd474da056d5a3396927e555d4395cd1ac13393fbb0682aa3fdc6c734b718c0451ebc SHA512 9a59cb814efe45123a5d8fc8fe8b81d068013c58fb6f4e04bd9c0267c4c5ec1f1b254770ba6f5e43a645093c84a477d903e5d981c89532732c840e2026ba40a0
diff --git a/dev-python/pytest-relaxed/files/pytest-relaxed-1.1.4-no-autoload.patch b/dev-python/pytest-relaxed/files/pytest-relaxed-1.1.4-no-autoload.patch
new file mode 100644
index 000000000000..b176e4e86c3e
--- /dev/null
+++ b/dev-python/pytest-relaxed/files/pytest-relaxed-1.1.4-no-autoload.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index 28c72c7..6feca5b 100644
+--- a/setup.py
++++ b/setup.py
+@@ -22,7 +22,6 @@ setup(
+ packages=find_packages(),
+ entry_points={
+ # TODO: do we need to name the LHS 'pytest_relaxed' too? meh
+- "pytest11": ["relaxed = pytest_relaxed.plugin"]
+ },
+ install_requires=[
+ # NOTE: pytest 3.3 broke something, not sure what yet
diff --git a/dev-python/pytest-relaxed/pytest-relaxed-1.1.4.ebuild b/dev-python/pytest-relaxed/pytest-relaxed-1.1.4.ebuild
new file mode 100644
index 000000000000..7ed7aeefa0e6
--- /dev/null
+++ b/dev-python/pytest-relaxed/pytest-relaxed-1.1.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for relaxed test discovery and organization"
+HOMEPAGE="https://pypi.org/project/pytest-relaxed/ https://github.com/bitprophet/pytest-relaxed"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pytest-3[${PYTHON_USEDEP}]
+ >=dev-python/six-1[${PYTHON_USEDEP}]
+ >=dev-python/decorator-4[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ # We strip pytest-relaxed's entry point to stop it from autoloading on all
+ # tests. When this package is installed, it has the habit of being
+ # autoloaded everywhere and break every test. If you want to load it, add
+ # "-p pytest_relaxed.plugin" to your pytest invocation.
+ "${FILESDIR}/${PN}-1.1.4-no-autoload.patch"
+)
+
+python_test() {
+ pytest -v || die "tests failed with ${EPYTHON}"
+}