summaryrefslogtreecommitdiff
path: root/dev-python/pytest-relaxed/pytest-relaxed-1.1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /dev-python/pytest-relaxed/pytest-relaxed-1.1.4.ebuild
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'dev-python/pytest-relaxed/pytest-relaxed-1.1.4.ebuild')
-rw-r--r--dev-python/pytest-relaxed/pytest-relaxed-1.1.4.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/pytest-relaxed/pytest-relaxed-1.1.4.ebuild b/dev-python/pytest-relaxed/pytest-relaxed-1.1.4.ebuild
index 7ed7aeefa0e6..5fc6498d150e 100644
--- a/dev-python/pytest-relaxed/pytest-relaxed-1.1.4.ebuild
+++ b/dev-python/pytest-relaxed/pytest-relaxed-1.1.4.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+# Because of its <pytest-3.3 constraint, python3_7 can't be added
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
inherit distutils-r1
@@ -13,15 +14,20 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="BSD-2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris"
IUSE="test"
RDEPEND="
>=dev-python/pytest-3[${PYTHON_USEDEP}]
+ <dev-python/pytest-3.3
>=dev-python/six-1[${PYTHON_USEDEP}]
>=dev-python/decorator-4[${PYTHON_USEDEP}]
"
+# This package is a broken mess upstream. Tests don't work. Fortunately, it's
+# not actually used by many packages.
+RESTRICT="test"
+
PATCHES=(
# We strip pytest-relaxed's entry point to stop it from autoloading on all
# tests. When this package is installed, it has the habit of being