summaryrefslogtreecommitdiff
path: root/dev-python/pytest-regressions
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-01 10:13:22 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-01 10:13:22 +0100
commitfbf0c3d1b463bf45fb0e9f119bec3424d6a44a4f (patch)
tree0577a4fd370ca08d8ba17250042db808c880e3d3 /dev-python/pytest-regressions
parentf3197c619cca64ce3915f6524d47c135b68a47f7 (diff)
gentoo auto-resync : 01:09:2023 - 10:13:22
Diffstat (limited to 'dev-python/pytest-regressions')
-rw-r--r--dev-python/pytest-regressions/Manifest2
-rw-r--r--dev-python/pytest-regressions/pytest-regressions-2.5.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/pytest-regressions/Manifest b/dev-python/pytest-regressions/Manifest
index cd08fab391d1..29ae27a29088 100644
--- a/dev-python/pytest-regressions/Manifest
+++ b/dev-python/pytest-regressions/Manifest
@@ -1,5 +1,7 @@
DIST pytest-regressions-2.4.2.tar.gz 111030 BLAKE2B 4c1d3ce9a210b6156e046b91688aec6ecab53d4719b5b556cdf6773a6af891352f7f213259140fdb7234f2528dbad5bf5c4ed43431aee94bfd373dd1839c1231 SHA512 f5abcc09da7a466e446329737d4926d3c7c9ac274e1087e6f746fe263b4cfd1b0f4b8870eea3d22b1209a0d5ead7b7169e700d10f3f29bb978e12a33511b1f51
DIST pytest-regressions-2.4.3.tar.gz 111049 BLAKE2B a9b11ec715c49f63c5972bad6332715b22efd363c70f067c4c077ae0e9af64178edb98aa36cd4d24287db4b2705367c18c09795b7830a09e2007c7da8a078964 SHA512 4264e2d791f6235b5de57a45550f8d0d0a6d3f7f10b40095698670daa8848005bc44c3cb2c11d793b58eb8b27e3910042c63fd4c0bd573ed57615d570e9e7d8b
+DIST pytest-regressions-2.5.0.tar.gz 113615 BLAKE2B 3364893a9cd96a44611d023c08fe5e319ceaad5a6a9b210b72095a560c42742c871406de1290821ea5cd61960bf5bef72d08bd143db93b20f288d5367cf1ae70 SHA512 2d23568b8d5dbc86000c9b552c72a1e269fafe79e0b829f799fe31ecc142e74d233c69940a51d2da457c6f7b3713fcd788461b0420eca9d56cc395568c517c0f
EBUILD pytest-regressions-2.4.2.ebuild 1559 BLAKE2B f870ad3f871567e31381fd45b26eb0ce1d071a8de80d18503725e6e2fab812b0c1419e828a2c8785c22dce04289ae8caca80ac2a46418d4c45dc724c09ecec8b SHA512 ca345109d180c0383f4aa3b3bc9a0a10e981e5497b2705f5f545c26abaf19135f0c64e48abe5abf739c4cf258dc0a7d6fec78c1b0d070b40c4d8591a237e6a88
EBUILD pytest-regressions-2.4.3.ebuild 1567 BLAKE2B 61de0756203c0b5330f1b40901b6ab9ac42cff0d96ea122b728548088a211953bd08f44e0da2dd04ad7b0c2b230369f29dd09b503ab7e341504a66d92e58b6d3 SHA512 f11353d9a7e9486c4bc84d33e8b7cece11fd1d0e16fe5244f880139dea9e51f4116f47195aea0f7886ffd734eb385fca1d84abd1b94d6ec354e637310c44cded
+EBUILD pytest-regressions-2.5.0.ebuild 1567 BLAKE2B 61de0756203c0b5330f1b40901b6ab9ac42cff0d96ea122b728548088a211953bd08f44e0da2dd04ad7b0c2b230369f29dd09b503ab7e341504a66d92e58b6d3 SHA512 f11353d9a7e9486c4bc84d33e8b7cece11fd1d0e16fe5244f880139dea9e51f4116f47195aea0f7886ffd734eb385fca1d84abd1b94d6ec354e637310c44cded
MISC metadata.xml 409 BLAKE2B 1a8e013ab1ca1f4c780de085dd52334bc89b1410a10004bf0f70bdec351e32e80a2bbf9af85aae8faeb364f5698a5e5049bead2045b7fa598cad21ba2fa68b4b SHA512 16f824d0dd5b7fb5794c4f1c39ffb92e0705209811b899fa364ebfd457e137ec6b5f7e1a894087ad7ff6dda2715beaa799166fbedc10a133ada865f69af612b4
diff --git a/dev-python/pytest-regressions/pytest-regressions-2.5.0.ebuild b/dev-python/pytest-regressions/pytest-regressions-2.5.0.ebuild
new file mode 100644
index 000000000000..2656b1b8d726
--- /dev/null
+++ b/dev-python/pytest-regressions/pytest-regressions-2.5.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easy to use fixtures to write regression tests"
+HOMEPAGE="
+ https://github.com/ESSS/pytest-regressions/
+ https://pypi.org/project/pytest-regressions/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-datadir[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/sphinx-rtd-theme
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ local EPYTEST_IGNORE=()
+ if ! has_version "dev-python/matplotlib[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_image_regression.py::test_image_regression
+ )
+ fi
+ if ! has_version "dev-python/numpy[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/test_ndarrays_regression.py
+ )
+ fi
+ if ! has_version "dev-python/pandas[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_filenames.py::test_foo
+ tests/test_filenames.py::TestClass::test_foo
+ tests/test_filenames.py::TestClassWithIgnoredName::test_foo
+ )
+ EPYTEST_IGNORE+=(
+ tests/test_dataframe_regression.py
+ tests/test_num_regression.py
+ )
+ fi
+ if ! has_version "dev-python/pillow[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_image_regression.py
+ )
+ fi
+
+ epytest
+}