summaryrefslogtreecommitdiff
path: root/dev-python/pytest-recording
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-30 23:46:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-30 23:46:05 +0000
commitbb262580ec0b56a32797f121e627928d103e6bb1 (patch)
treeb3b80cb753a087635c972352ce99fed1d01f286b /dev-python/pytest-recording
parent35e3ee5faf74dc69409f957f81a6848d4d24c49f (diff)
gentoo auto-resync : 30:12:2023 - 23:46:05
Diffstat (limited to 'dev-python/pytest-recording')
-rw-r--r--dev-python/pytest-recording/Manifest2
-rw-r--r--dev-python/pytest-recording/pytest-recording-0.13.0.ebuild46
2 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/pytest-recording/Manifest b/dev-python/pytest-recording/Manifest
index 6d2ad3116735..257743fe6d7f 100644
--- a/dev-python/pytest-recording/Manifest
+++ b/dev-python/pytest-recording/Manifest
@@ -1,5 +1,3 @@
-DIST pytest_recording-0.13.0.tar.gz 25027 BLAKE2B c325aaf809617886e85c3fa597c36858c7e1a9cb1552a18c8ee27f5a7479b66469b61bce51ceb14fc9dd5fa420c20803ed016875eef1a0cf05de5293ead24bfc SHA512 2e9ab39971d89f838f2d778d1d80fdb5519b39855a69019eeeb22d69ca3c92ecb14a7eda7b55ec37ea07fae0c3316c9c16932a0afcf0abe0dbfefc31fe23bd68
DIST pytest_recording-0.13.1.tar.gz 24987 BLAKE2B 70c7d65823e1a6507353dcab61659a4fe05a4f3d81471dfa3818ca34f6b6c1c22444ee6c1d04b67e87db93ffba63e8bf091beb7d3f60723bc1f7fa8dfde641cd SHA512 1f815b45361165a9fa2655c0cfb5a69193a556e748dc5d69aac0f49a36e943a60a990c3f503a29aae58f9409661f5f47041a30766fb1b5276789eec255b1556b
-EBUILD pytest-recording-0.13.0.ebuild 1059 BLAKE2B b1e7439a2fc593f494c7fdc4368adf95676bdf77007aecbef71f474c95c7649249b6b17d0f0a2de3a82d2f23e69000c6d1617a5e38cf059b39c2ae76c6ae3ef2 SHA512 b5481a15c20e6fd0f952914644e44b03e82fb1240aeb02bce896fbbf0a6b8d450c90a31cfe5d21856751dc4acc3d8af1be3443cd511eaa55bb7d74cec599dc87
EBUILD pytest-recording-0.13.1.ebuild 1059 BLAKE2B b1e7439a2fc593f494c7fdc4368adf95676bdf77007aecbef71f474c95c7649249b6b17d0f0a2de3a82d2f23e69000c6d1617a5e38cf059b39c2ae76c6ae3ef2 SHA512 b5481a15c20e6fd0f952914644e44b03e82fb1240aeb02bce896fbbf0a6b8d450c90a31cfe5d21856751dc4acc3d8af1be3443cd511eaa55bb7d74cec599dc87
MISC metadata.xml 386 BLAKE2B 315ecea597106e9df678c10b0c5b24432795ddfaa07a8a7ae35361e3539ce31ceb1759c6bf49f5b588804d3b66157d599a8ae0858b5b8bca7972a58439bc8c64 SHA512 f652dd2ddf5752c2d5d022e8ad6cd68dee0f8421e71bf618a42e7e4786f61deda68316f9f8e518f34a761aaf1c9d48f55b7d49ba0a7a547f517436cfc781e2c9
diff --git a/dev-python/pytest-recording/pytest-recording-0.13.0.ebuild b/dev-python/pytest-recording/pytest-recording-0.13.0.ebuild
deleted file mode 100644
index 2a204e0b665c..000000000000
--- a/dev-python/pytest-recording/pytest-recording-0.13.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A pytest plugin to record network interactions via VCR.py"
-HOMEPAGE="
- https://pypi.org/project/pytest-recording/
- https://github.com/kiwicom/pytest-recording/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-
-RDEPEND="
- >=dev-python/pytest-3.5.0[${PYTHON_USEDEP}]
- >=dev-python/vcrpy-2.0.1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test () {
- local EPYTEST_DESELECT=(
- # Internet
- # https://github.com/kiwicom/pytest-recording/issues/131
- tests/test_blocking_network.py::test_block_network_with_allowed_hosts
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_recording.plugin
- PYTEST_PLUGINS+=,pytest_httpbin.plugin,pytest_mock
- epytest
-}