summaryrefslogtreecommitdiff
path: root/dev-python/pytest-recording
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-22 14:44:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-22 14:44:10 +0100
commit63627de4936707c40b5c4dca4f23e9fe1e9c4837 (patch)
tree0882ba9f0e330ae7e1f2f3306a6683000060355d /dev-python/pytest-recording
parent940cec7afea0fff03b206c62a512335e6f9d2d00 (diff)
gentoo auto-resync : 22:10:2023 - 14:44:09
Diffstat (limited to 'dev-python/pytest-recording')
-rw-r--r--dev-python/pytest-recording/Manifest3
-rw-r--r--dev-python/pytest-recording/metadata.xml12
-rw-r--r--dev-python/pytest-recording/pytest-recording-0.13.0.ebuild46
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/pytest-recording/Manifest b/dev-python/pytest-recording/Manifest
new file mode 100644
index 000000000000..e5c15ad023ea
--- /dev/null
+++ b/dev-python/pytest-recording/Manifest
@@ -0,0 +1,3 @@
+DIST pytest_recording-0.13.0.tar.gz 25027 BLAKE2B c325aaf809617886e85c3fa597c36858c7e1a9cb1552a18c8ee27f5a7479b66469b61bce51ceb14fc9dd5fa420c20803ed016875eef1a0cf05de5293ead24bfc SHA512 2e9ab39971d89f838f2d778d1d80fdb5519b39855a69019eeeb22d69ca3c92ecb14a7eda7b55ec37ea07fae0c3316c9c16932a0afcf0abe0dbfefc31fe23bd68
+EBUILD pytest-recording-0.13.0.ebuild 1052 BLAKE2B 0aef24005d1eafcfc347c300d8bf110b13381718dfec2d58964252b9846976ef6a0ecc55e3c671d2c46f5c233ca6cb51785241bf6277f02f484ad4661034595b SHA512 6f597fa60f6234ac95ef320d1183e831f35003409535017099f08f94c482302377b76e2d82efca66536b268faaf7f733330a156dae6b08e4e012f770a3ce29ac
+MISC metadata.xml 386 BLAKE2B 315ecea597106e9df678c10b0c5b24432795ddfaa07a8a7ae35361e3539ce31ceb1759c6bf49f5b588804d3b66157d599a8ae0858b5b8bca7972a58439bc8c64 SHA512 f652dd2ddf5752c2d5d022e8ad6cd68dee0f8421e71bf618a42e7e4786f61deda68316f9f8e518f34a761aaf1c9d48f55b7d49ba0a7a547f517436cfc781e2c9
diff --git a/dev-python/pytest-recording/metadata.xml b/dev-python/pytest-recording/metadata.xml
new file mode 100644
index 000000000000..9fa86cdaa74d
--- /dev/null
+++ b/dev-python/pytest-recording/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">kiwicom/pytest-recording</remote-id>
+ <remote-id type="pypi">pytest-recording</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-recording/pytest-recording-0.13.0.ebuild b/dev-python/pytest-recording/pytest-recording-0.13.0.ebuild
new file mode 100644
index 000000000000..a5f981d06b75
--- /dev/null
+++ b/dev-python/pytest-recording/pytest-recording-0.13.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pytest plugin to record network interactions via VCR.py"
+HOMEPAGE="
+ https://pypi.org/project/pytest-recording/
+ https://github.com/kiwicom/pytest-recording/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pytest-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/vcrpy-2.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test () {
+ local EPYTEST_DESELECT=(
+ # Internet
+ # https://github.com/kiwicom/pytest-recording/issues/131
+ tests/test_blocking_network.py::test_block_network_with_allowed_hosts
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_recording.plugin
+ PYTEST_PLUGINS+=,pytest_httpbin.plugin,pytest_mock
+ epytest
+}