summaryrefslogtreecommitdiff
path: root/dev-python/pytest-qt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-22 17:18:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-22 17:18:34 +0000
commitfd87b7c771378b2116981e3924bee5805148e118 (patch)
tree91ed28393c7b534787d3c073e269fe598d0fd535 /dev-python/pytest-qt
parent77b74be093bdf4a0ed4121acc3f8e229103cf004 (diff)
gentoo auto-resync : 22:11:2023 - 17:18:34
Diffstat (limited to 'dev-python/pytest-qt')
-rw-r--r--dev-python/pytest-qt/Manifest2
-rw-r--r--dev-python/pytest-qt/pytest-qt-4.2.0.ebuild38
2 files changed, 19 insertions, 21 deletions
diff --git a/dev-python/pytest-qt/Manifest b/dev-python/pytest-qt/Manifest
index fa448a86b31e..b2f7032a6ced 100644
--- a/dev-python/pytest-qt/Manifest
+++ b/dev-python/pytest-qt/Manifest
@@ -1,3 +1,3 @@
DIST pytest-qt-4.2.0.tar.gz 120749 BLAKE2B 1986bbf4ebc578ad548d2fcc8888b0d0fb42f75ad8a03f315f51c04ae466587d3299fca8ec3a49bc5d023fc8ca76cbe6c45728bc88609e20d6f68ea8c6ea204e SHA512 57e175bada0e33101eeb7d85579f6e804658d74168714b117b3a1ba564826405e70860b258caf28c917ddca7acd1842de2133a55b342862762fc37ca1a758b69
-EBUILD pytest-qt-4.2.0.ebuild 2047 BLAKE2B 4655996c3fbd5c0a8afde7c8b2658c7217e0464f29026d291c2690293d2e01762b62490e2f6a496d776bb3677d8db4b84942fcf06c8721f403251808a358972f SHA512 2bbef88799f425cee754e76a40fe7cf74d414e448c840922c2825edc0568a72c2967a5a5c4dfe27d25b837394abba09c589f33a6ca23457dbcd6d59353790f55
+EBUILD pytest-qt-4.2.0.ebuild 1964 BLAKE2B da1736ae878d459ba15c719c936f2f4d43e41dc395818054264609d617cf85cd8ec942129763c06039ccd369135833b8d7867d18109a0fdb1f8f25571ec0f5f6 SHA512 81021039d3291725476e1519ed4b1a68cec8744dda127a148d27c88b86c3418170c56522ee7c24fdea3cbb649bdf2236060574d53675f70af3901d4c7ad29abd
MISC metadata.xml 516 BLAKE2B be5241e39f672681b27a003d02eca0e047644cad7da57de6b3393f58760c094c1661b9d168e44bea4efd56b38225d49abd5be6e71031a0d854b878716286d3ed SHA512 77981d63d3214fd2c052f8a7eac1a439899318973807299237a9105730893ce01d4423b060f532bd4f4496418683fc5128508c7d8747ba6ee6ed0eae67e5569f
diff --git a/dev-python/pytest-qt/pytest-qt-4.2.0.ebuild b/dev-python/pytest-qt/pytest-qt-4.2.0.ebuild
index 6c843c8a73e3..69e99e252e64 100644
--- a/dev-python/pytest-qt/pytest-qt-4.2.0.ebuild
+++ b/dev-python/pytest-qt/pytest-qt-4.2.0.ebuild
@@ -25,13 +25,13 @@ RDEPEND="
"
BDEPEND="
test? (
- dev-python/PyQt5[gui,testlib,widgets,${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/pyside2[gui,testlib,widgets,${PYTHON_USEDEP}]
- ' "${PYSIDE2_COMPAT[@]}")
- amd64? (
+ || (
dev-python/PyQt6[gui,testlib,widgets,${PYTHON_USEDEP}]
+ dev-python/PyQt5[gui,testlib,widgets,${PYTHON_USEDEP}]
dev-python/pyside6[gui,testlib,widgets,${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pyside2[gui,testlib,widgets,${PYTHON_USEDEP}]
+ ' "${PYSIDE2_COMPAT[@]}")
)
)
"
@@ -53,25 +53,23 @@ python_test() {
# to be possible inside Xvfb
"tests/test_basics.py::test_wait_window[waitActive-True]"
+ # TODO
+ tests/test_exceptions.py::test_exceptions_dont_leak
+
# we are forcing a specific module via envvar, effectively
# overriding the config
tests/test_basics.py::test_qt_api_ini_config
tests/test_basics.py::test_qt_api_ini_config_with_envvar
)
- einfo "Testing with PyQt5"
- PYTEST_QT_API="pyqt5" epytest || die
- if use amd64; then
- einfo "Testing with PyQt6"
- PYTEST_QT_API="pyqt6" epytest || die
- fi
- # Pyside{2,6} is not compatible with python3.12
- if has "${EPYTHON}" "${PYSIDE2_COMPAT[@]/_/.}"; then
- einfo "Testing with PySide2"
- PYTEST_QT_API="pyside2" epytest || die
- fi
- if use amd64 && has "${EPYTHON}" "${PYSIDE6_COMPAT[@]/_/.}"; then
- einfo "Testing with PySide6"
- PYTEST_QT_API="pyside6" epytest || die
- fi
+ local -x PYTEST_QT_API
+ for PYTEST_QT_API in PyQt{5,6} pyside{2,6}; do
+ if has_version "dev-python/${PYTEST_QT_API}[gui,testlib,widgets,${PYTHON_USEDEP}]"
+ then
+ einfo "Testing with ${EPYTHON} and ${PYTEST_QT_API}"
+ nonfatal epytest ||
+ die -n "Tests failed with ${EPYTHON} and ${PYTEST_QT_API}" ||
+ return 1
+ fi
+ done
}