summaryrefslogtreecommitdiff
path: root/dev-python/pytest-qt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-21 21:44:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-21 21:44:48 +0100
commitd51fe7680c5270ddf8d324bbe11caab6d1e27ade (patch)
treea895b5889d79dbbb9aa52995fcac4816acfa07c1 /dev-python/pytest-qt
parent7d52991b5dce3a07be15d3cbbf06abb3fc08cb9c (diff)
gentoo auto-resync : 21:08:2023 - 21:44:47
Diffstat (limited to 'dev-python/pytest-qt')
-rw-r--r--dev-python/pytest-qt/Manifest2
-rw-r--r--dev-python/pytest-qt/pytest-qt-4.2.0.ebuild23
2 files changed, 21 insertions, 4 deletions
diff --git a/dev-python/pytest-qt/Manifest b/dev-python/pytest-qt/Manifest
index cba9cf1a0c48..3a210fb873f7 100644
--- a/dev-python/pytest-qt/Manifest
+++ b/dev-python/pytest-qt/Manifest
@@ -1,3 +1,3 @@
DIST pytest-qt-4.2.0.tar.gz 120749 BLAKE2B 1986bbf4ebc578ad548d2fcc8888b0d0fb42f75ad8a03f315f51c04ae466587d3299fca8ec3a49bc5d023fc8ca76cbe6c45728bc88609e20d6f68ea8c6ea204e SHA512 57e175bada0e33101eeb7d85579f6e804658d74168714b117b3a1ba564826405e70860b258caf28c917ddca7acd1842de2133a55b342862762fc37ca1a758b69
-EBUILD pytest-qt-4.2.0.ebuild 1666 BLAKE2B ec78b5f1932e250c78fd18efc17cdbb2cf19a39d4db1c9a730dc4293a8fc8631dd4cf3d06202a0e15e211feae00a85aac9ee82a02d83b4ed82e7c1aa27797490 SHA512 efa987e878b227b383b30d8a06788f1fe1c9c5152201b1df3a9e5f3373c1f59a2b19b97e73e60342ec503ba3c956dd5b5672d2971bdafa5b82ad33b25ff85f8e
+EBUILD pytest-qt-4.2.0.ebuild 2148 BLAKE2B 8ea6ea99a8ef52c60b5d852f52c656d7ea2493e234740808fed947e0e9eb18dddce081beff153882892f338e47c9210b110575e1b88b4e8e6cd3c7c6f8f1cc7c SHA512 da767f23a44016e01f7e0763611c70801d9cb989175be4557526a4a46860313a36b6ef23e75ed90e6ba66f8f759b7415d37f20d8186b5330ee5220f5bd50c7cb
MISC metadata.xml 516 BLAKE2B be5241e39f672681b27a003d02eca0e047644cad7da57de6b3393f58760c094c1661b9d168e44bea4efd56b38225d49abd5be6e71031a0d854b878716286d3ed SHA512 77981d63d3214fd2c052f8a7eac1a439899318973807299237a9105730893ce01d4423b060f532bd4f4496418683fc5128508c7d8747ba6ee6ed0eae67e5569f
diff --git a/dev-python/pytest-qt/pytest-qt-4.2.0.ebuild b/dev-python/pytest-qt/pytest-qt-4.2.0.ebuild
index 81b76782132f..5c321c7bdf1f 100644
--- a/dev-python/pytest-qt/pytest-qt-4.2.0.ebuild
+++ b/dev-python/pytest-qt/pytest-qt-4.2.0.ebuild
@@ -5,8 +5,9 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} )
-PYSIDE2_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{10..12} )
+PYSIDE2_COMPAT=( python3_{10..11} )
+PYSIDE6_COMPAT=( python3_{10..11} )
inherit distutils-r1 virtualx pypi
@@ -26,9 +27,17 @@ RDEPEND="
BDEPEND="
test? (
dev-python/PyQt5[gui,testlib,widgets,${PYTHON_USEDEP}]
+ amd64? (
+ dev-python/PyQt6[gui,testlib,widgets,${PYTHON_USEDEP}]
+ )
$(python_gen_cond_dep '
dev-python/pyside2[gui,testlib,widgets,${PYTHON_USEDEP}]
' "${PYSIDE2_COMPAT[@]}")
+ amd64? (
+ $(python_gen_cond_dep '
+ dev-python/pyside6[gui,testlib,widgets,${PYTHON_USEDEP}]
+ ' "${PYSIDE6_COMPAT[@]}")
+ )
)
"
@@ -57,9 +66,17 @@ python_test() {
einfo "Testing with PyQt5"
PYTEST_QT_API="pyqt5" epytest || die
- # Pyside2 is not compatible with python3.11
+ if use amd64; then
+ einfo "Testing with PyQt6"
+ PYTEST_QT_API="pyqt6" epytest || die
+ fi
+ # Pyside{2,6} is not compatible with python3.12
if has "${EPYTHON}" "${PYSIDE2_COMPAT[@]/_/.}"; then
einfo "Testing with PySide2"
PYTEST_QT_API="pyside2" epytest || die
fi
+ if use amd64 && has "${EPYTHON}" "${PYSIDE6_COMPAT[@]/_/.}"; then
+ einfo "Testing with PySide6"
+ PYTEST_QT_API="pyside6" epytest || die
+ fi
}