summaryrefslogtreecommitdiff
path: root/dev-python/pytest-qt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-26 09:55:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-26 09:55:31 +0100
commit9a8514e070a40648dbc8e28ad6457d925542b79a (patch)
tree5cc8ed0b0c8964ad196b7b3e502def202a997b32 /dev-python/pytest-qt
parent2ecd7994be1409f2a65bfca700904d2a78fd7bbe (diff)
gentoo auto-resync : 26:10:2022 - 09:55:31
Diffstat (limited to 'dev-python/pytest-qt')
-rw-r--r--dev-python/pytest-qt/Manifest2
-rw-r--r--dev-python/pytest-qt/pytest-qt-4.2.0.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/pytest-qt/Manifest b/dev-python/pytest-qt/Manifest
index f76b85617927..43523771667c 100644
--- a/dev-python/pytest-qt/Manifest
+++ b/dev-python/pytest-qt/Manifest
@@ -1,3 +1,5 @@
DIST pytest-qt-4.1.0.tar.gz 119702 BLAKE2B 7c906c94761df6472ae65a6ebb38dff07de8156730e3e10615ea8e08f0bd9f9fee07127ee6e8616055117b1db1911bc9b4486345d84b249664d317561195ad77 SHA512 bfb56abbaac47bf9da26eb19d6913d59872f2a9923da339e9a30a2145d0a094ddec36bcfa21d39c4cf318f95a83c72c249fe70034294a6791f9d84345f77451d
+DIST pytest-qt-4.2.0.tar.gz 120749 BLAKE2B 1986bbf4ebc578ad548d2fcc8888b0d0fb42f75ad8a03f315f51c04ae466587d3299fca8ec3a49bc5d023fc8ca76cbe6c45728bc88609e20d6f68ea8c6ea204e SHA512 57e175bada0e33101eeb7d85579f6e804658d74168714b117b3a1ba564826405e70860b258caf28c917ddca7acd1842de2133a55b342862762fc37ca1a758b69
EBUILD pytest-qt-4.1.0.ebuild 1693 BLAKE2B 33e32b2abcf8bc6cc3bf74dad84f5fef6644e66e8a8a7fe24a27b4c28c371aa35c410c2ac712dd0cc5722c504bdc323100c67b2e687f2726791712e23cdb7f53 SHA512 7003c9b7b2cdc7d0e91db559e55413361bae52046613c60004656860b229dbe18ce1118f9f305769444cb3609207da2f21c44088231cd9335559a0753c960a2d
+EBUILD pytest-qt-4.2.0.ebuild 1695 BLAKE2B 11efdcf4e0ce3ef578e9a803476c0928f94ed3a8fe41caba28c6263c3d1996896370002347b8c9b7dc109faa26986971e0950e705394a02b222c7ce1306ccbd6 SHA512 238e661ac00081736d35fa3284f83f7e57d72e21c5ba34a91ccb171de511cee4c566dc197a397e8e44471fe1c4f9d34f53911754ecdf41c52ea591e18e4bda82
MISC metadata.xml 516 BLAKE2B be5241e39f672681b27a003d02eca0e047644cad7da57de6b3393f58760c094c1661b9d168e44bea4efd56b38225d49abd5be6e71031a0d854b878716286d3ed SHA512 77981d63d3214fd2c052f8a7eac1a439899318973807299237a9105730893ce01d4423b060f532bd4f4496418683fc5128508c7d8747ba6ee6ed0eae67e5569f
diff --git a/dev-python/pytest-qt/pytest-qt-4.2.0.ebuild b/dev-python/pytest-qt/pytest-qt-4.2.0.ebuild
new file mode 100644
index 000000000000..69dbc6a6d79f
--- /dev/null
+++ b/dev-python/pytest-qt/pytest-qt-4.2.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+PYSIDE2_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Pytest plugin for PyQt5 and PySide2 applications"
+HOMEPAGE="
+ https://pypi.org/project/pytest-qt/
+ https://github.com/pytest-dev/pytest-qt/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/QtPy[gui,testlib,widgets(+),${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/PyQt5[gui,testlib,widgets,${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pyside2[gui,testlib,widgets,${PYTHON_USEDEP}]
+ ' "${PYSIDE2_COMPAT[@]}")
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ # warnings from other plugins cause the test output matchers to fail
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytestqt.plugin
+
+ local EPYTEST_DESELECT=(
+ # requires the window to be activated; that doesn't seem
+ # to be possible inside Xvfb
+ "tests/test_basics.py::test_wait_window[waitActive-True]"
+
+ # we are forcing a specific module via envvar, effectively
+ # overriding the config
+ tests/test_basics.py::test_qt_api_ini_config
+ tests/test_basics.py::test_qt_api_ini_config_with_envvar
+ )
+
+ einfo "Testing with PyQt5"
+ PYTEST_QT_API="pyqt5" epytest || die
+ # Pyside2 is not compatible with python3.11
+ if has "${EPYTHON}" "${PYSIDE2_COMPAT[@]/_/.}"; then
+ einfo "Testing with PySide2"
+ PYTEST_QT_API="pyside2" epytest || die
+ fi
+}