summaryrefslogtreecommitdiff
path: root/dev-python/pytest-qt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pytest-qt
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pytest-qt')
-rw-r--r--dev-python/pytest-qt/Manifest3
-rw-r--r--dev-python/pytest-qt/metadata.xml12
-rw-r--r--dev-python/pytest-qt/pytest-qt-2.3.0-r2.ebuild41
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pytest-qt/Manifest b/dev-python/pytest-qt/Manifest
new file mode 100644
index 000000000000..12d6feb9dca9
--- /dev/null
+++ b/dev-python/pytest-qt/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-qt-2.3.0.tar.gz 106707 BLAKE2B cf02aed42481cbcadfaaa15c883f3055337f6f32e33b7dfbce986ecd9936218ee5bfe9f21e1a910aa970e7adf88dd24415d63f40655e8417863e96a4285fd466 SHA512 2bda4b5f60ba68b151ce62972661cd704e40f4cadaef2583882099e96100b5c5b9398de796e851579e026e9736e07539c4db8c10eef16929ce729c4dd7a22940
+EBUILD pytest-qt-2.3.0-r2.ebuild 900 BLAKE2B 7b5c214e8359e8a8120cffd3d9279636b368a4490af212fc5b29e8d7f659e448e581adbc9f88807f0337cb5d4eb3b7d4ce11706ae4c1bcffd9875ca2dde34909 SHA512 9c0c9c6a8c1c135b14300ae2064afd104cde04465cd5a730bceefca3fc9008816f7738868c0f554d94f00f1dad8b7d8766aa9a00bea5ba3528e0d491e7ac17e3
+MISC metadata.xml 396 BLAKE2B f4d5cdd1823e62b7b0443623b9f34ffbd2f5f7944ddca44dacbeba2b4a3daa438203483b96f113ab821d4e5dccdc6e9cde8faa3a6a4a53d190b567af07cb9b61 SHA512 c5c3149a783a4d72eb7f0582d416b0f6c408d86878892a0ccde2aa5ec672a55c0c2658af31cffdd8f66500420fa3ee43dbda98397a1efb3cc06697e9e1af84ac
diff --git a/dev-python/pytest-qt/metadata.xml b/dev-python/pytest-qt/metadata.xml
new file mode 100644
index 000000000000..2b11b948e3b9
--- /dev/null
+++ b/dev-python/pytest-qt/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-qt</remote-id>
+ <remote-id type="github">pytest-dev/pytest-qt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-qt/pytest-qt-2.3.0-r2.ebuild b/dev-python/pytest-qt/pytest-qt-2.3.0-r2.ebuild
new file mode 100644
index 000000000000..a62c2f52ae2b
--- /dev/null
+++ b/dev-python/pytest-qt/pytest-qt-2.3.0-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for PyQt4 or PyQt5 applications"
+HOMEPAGE="https://pypi.org/project/pytest-qt/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/pytest-2.7.0[${PYTHON_USEDEP}]
+ dev-python/PyQt5[gui,testlib,${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-py3doc-enhanced-theme[${PYTHON_USEDEP}]
+ )
+"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# Test make assumptions about Qt environment
+RESTRICT="test"
+
+python_compile_all() {
+ use doc && sphinx-build -b html docs _build/html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( _build/html/. )
+ distutils-r1_python_install_all
+}