summaryrefslogtreecommitdiff
path: root/dev-python/pytest-qt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-06 12:54:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-06 12:54:39 +0000
commit56330f065f2b903d9e1b2dffc63719fef5897a45 (patch)
tree659a7ebca7cb9f7504b018c1484df84ba4f9ab01 /dev-python/pytest-qt
parent1774f0a748546cbd792bf1eb44757b63be2e0114 (diff)
gentoo auto-resync : 06:01:2024 - 12:54:38
Diffstat (limited to 'dev-python/pytest-qt')
-rw-r--r--dev-python/pytest-qt/Manifest4
-rw-r--r--dev-python/pytest-qt/pytest-qt-4.2.0.ebuild77
-rw-r--r--dev-python/pytest-qt/pytest-qt-4.3.1.ebuild4
3 files changed, 3 insertions, 82 deletions
diff --git a/dev-python/pytest-qt/Manifest b/dev-python/pytest-qt/Manifest
index 4f3e3639805e..f6e6c5498d73 100644
--- a/dev-python/pytest-qt/Manifest
+++ b/dev-python/pytest-qt/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-qt-4.2.0.tar.gz 120749 BLAKE2B 1986bbf4ebc578ad548d2fcc8888b0d0fb42f75ad8a03f315f51c04ae466587d3299fca8ec3a49bc5d023fc8ca76cbe6c45728bc88609e20d6f68ea8c6ea204e SHA512 57e175bada0e33101eeb7d85579f6e804658d74168714b117b3a1ba564826405e70860b258caf28c917ddca7acd1842de2133a55b342862762fc37ca1a758b69
DIST pytest-qt-4.3.1.tar.gz 125223 BLAKE2B b7ea852b4f0a97950ff4b8f03983639a30dcd8b3532a52f0d78a5074d1220817a0853a040eba71798fd74fba27cd77eeafff2cf12b177693d77f9bd954d841a4 SHA512 e77bd0817f9dfb492ddcd9cb605b07d1e468ce7b52dce7519f2f96afd004f7796a028998572c589444e9737278a84efb887c801fb3bcc79a71c48ab849070114
-EBUILD pytest-qt-4.2.0.ebuild 2094 BLAKE2B 814e1b677bb154ee0bbdc0da14f38dc0127bec3acd2fe887c65943726199bae389a2b20cf61e36ec5d34f1e71cca7572876e082ab9867905fec88b809b16a00d SHA512 a7030752d8b99882a39d16b5966689c1213d464584946dd58c50e63a6331d47c98365d78c33a075eb805dfeaa1dcbf1c717bfcbce48caf4f42a6ba3a33857a1d
-EBUILD pytest-qt-4.3.1.ebuild 2097 BLAKE2B fb810c58c276bd5de4b7f690c27ea9930e9fc2f55ee6cf6d09145dbe83ba895fa5b93a38e0acfbaafb689b2a7e2a572237a34c417302b0b0d266e0445d16db1b SHA512 5cd95cc8baf557cd9c1712312bea0dbc0b4ba53ffb1222a20a3d2efc181f89bc1cbb59cdbf98bea16fb4770b454ee88eba2f1d8e2c383d2e62b8efe80956d1a7
+EBUILD pytest-qt-4.3.1.ebuild 2094 BLAKE2B 597ba8677b1707c198903dcc019f71c9e027a19f627182d3fcf3755ec6be6545c0803c07fb66de592d1b17ff6159a00d43221058961042f726bf4de2235d4e43 SHA512 f66368fa1a34b41d29876c51fd9df2870029b5842d08da254dc745764d8b59b417c8a402228682ede8430c7cee5fc32d0b9ad2b585021b0fc414cda6a3ce6707
MISC metadata.xml 516 BLAKE2B be5241e39f672681b27a003d02eca0e047644cad7da57de6b3393f58760c094c1661b9d168e44bea4efd56b38225d49abd5be6e71031a0d854b878716286d3ed SHA512 77981d63d3214fd2c052f8a7eac1a439899318973807299237a9105730893ce01d4423b060f532bd4f4496418683fc5128508c7d8747ba6ee6ed0eae67e5569f
diff --git a/dev-python/pytest-qt/pytest-qt-4.2.0.ebuild b/dev-python/pytest-qt/pytest-qt-4.2.0.ebuild
deleted file mode 100644
index 852f4f554529..000000000000
--- a/dev-python/pytest-qt/pytest-qt-4.2.0.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
-PYSIDE2_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 virtualx pypi
-
-DESCRIPTION="Pytest plugin for PyQt5 and PySide2 applications"
-HOMEPAGE="
- https://pypi.org/project/pytest-qt/
- https://github.com/pytest-dev/pytest-qt/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
-
-RDEPEND="
- dev-python/QtPy[gui,testlib,widgets(+),${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- || (
- dev-python/PyQt6[gui,testlib,widgets,${PYTHON_USEDEP}]
- dev-python/PyQt5[gui,testlib,widgets,${PYTHON_USEDEP}]
- dev-python/pyside6[gui,testlib,widgets,${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/pyside2[gui,testlib,widgets,${PYTHON_USEDEP}]
- ' "${PYSIDE2_COMPAT[@]}")
- )
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- # warnings from other plugins cause the test output matchers to fail
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytestqt.plugin
-
- local EPYTEST_DESELECT=(
- # requires the window to be activated; that doesn't seem
- # to be possible inside Xvfb
- "tests/test_basics.py::test_wait_window[waitActive-True]"
-
- # TODO
- tests/test_exceptions.py::test_exceptions_dont_leak
-
- # we are forcing a specific module via envvar, effectively
- # overriding the config
- tests/test_basics.py::test_qt_api_ini_config
- tests/test_basics.py::test_qt_api_ini_config_with_envvar
- )
-
- local -x PYTEST_QT_API
- for PYTEST_QT_API in PyQt{5,6} pyside{2,6}; do
- if has_version "dev-python/${PYTEST_QT_API}[gui,testlib,widgets,${PYTHON_USEDEP}]"
- then
- einfo "Testing with ${EPYTHON} and ${PYTEST_QT_API}"
- # force-disable xfail_strict as upstream as xfail assumptions
- # don't seem to hold on arm64
- nonfatal epytest -oxfail_strict=false ||
- die -n "Tests failed with ${EPYTHON} and ${PYTEST_QT_API}" ||
- return 1
- fi
- done
-}
diff --git a/dev-python/pytest-qt/pytest-qt-4.3.1.ebuild b/dev-python/pytest-qt/pytest-qt-4.3.1.ebuild
index 1c783c234701..796985b7894a 100644
--- a/dev-python/pytest-qt/pytest-qt-4.3.1.ebuild
+++ b/dev-python/pytest-qt/pytest-qt-4.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,7 +18,7 @@ HOMEPAGE="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
RDEPEND="
dev-python/QtPy[gui,testlib,widgets(+),${PYTHON_USEDEP}]