summaryrefslogtreecommitdiff
path: root/dev-python/pytest-qt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-25 15:22:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-25 15:22:17 +0100
commit22910f5d14da606bd7f06e19a2f61c5d1a8fc94b (patch)
tree808b5701901fb54b53ec3ecf6f33272e933f3ea6 /dev-python/pytest-qt
parent91c0ec2d7067f6ab1ef578bd9967b32ca07eb502 (diff)
gentoo resync : 25.05.2018
Diffstat (limited to 'dev-python/pytest-qt')
-rw-r--r--dev-python/pytest-qt/Manifest3
-rw-r--r--dev-python/pytest-qt/pytest-qt-2.3.0-r2.ebuild2
-rw-r--r--dev-python/pytest-qt/pytest-qt-2.3.0.ebuild44
3 files changed, 2 insertions, 47 deletions
diff --git a/dev-python/pytest-qt/Manifest b/dev-python/pytest-qt/Manifest
index e7eb894425df..4b1cc51e681b 100644
--- a/dev-python/pytest-qt/Manifest
+++ b/dev-python/pytest-qt/Manifest
@@ -1,4 +1,3 @@
DIST pytest-qt-2.3.0.tar.gz 106707 BLAKE2B cf02aed42481cbcadfaaa15c883f3055337f6f32e33b7dfbce986ecd9936218ee5bfe9f21e1a910aa970e7adf88dd24415d63f40655e8417863e96a4285fd466 SHA512 2bda4b5f60ba68b151ce62972661cd704e40f4cadaef2583882099e96100b5c5b9398de796e851579e026e9736e07539c4db8c10eef16929ce729c4dd7a22940
-EBUILD pytest-qt-2.3.0-r2.ebuild 898 BLAKE2B 93896676ce2eae8c92c0723a0ed17abc5111472b9adccd9aff9ec2ff5b7bd5a930fee13f230f16b9b1c7dd585da9184d2e36f0c3b2fc493d0f81cb17c03f216e SHA512 d5629a1ae9fd63c4ca68a39920ff8bc09bfb5eb2809eb7e8e5ad944125da43d1c25103f5bb19ece5d6df114de18db411bf967592ae534953ef5c632b5ecf4eb2
-EBUILD pytest-qt-2.3.0.ebuild 895 BLAKE2B 85e2e6be2549fc346a269d94843d9236005a475a82111f0b56ff1c95c9a3d87d8ea4be993336dd922950e3a5cd3439dbe761807b0b2ffa5b241f397f1ea28abd SHA512 1d55f16fe7cb6d8080043a2c3636271bba15ddf6a5224d4d5ededdda90a82622afdd18a55289c6f9b7f17fc87fb38ec2201d243cd95411bd14b9a52aa96e7689
+EBUILD pytest-qt-2.3.0-r2.ebuild 896 BLAKE2B b0a17c21a33f7d2a87aa4c42870f2659303e7a2b61226910aa05b87ff71368e9313f630cbb1fc3adf4f24369531d79797f6e6f35bdd1fdc63a1efc02aa4ef347 SHA512 f7d3d485faa99852554b5a05ffc4b1fd08adf6aa60fff2203ea35a4b2bf74545cf1563313caea7ee6b576d3ef3dee08c3fe951609e8b2087c065cb4f109cffc2
MISC metadata.xml 396 BLAKE2B f4d5cdd1823e62b7b0443623b9f34ffbd2f5f7944ddca44dacbeba2b4a3daa438203483b96f113ab821d4e5dccdc6e9cde8faa3a6a4a53d190b567af07cb9b61 SHA512 c5c3149a783a4d72eb7f0582d416b0f6c408d86878892a0ccde2aa5ec672a55c0c2658af31cffdd8f66500420fa3ee43dbda98397a1efb3cc06697e9e1af84ac
diff --git a/dev-python/pytest-qt/pytest-qt-2.3.0-r2.ebuild b/dev-python/pytest-qt/pytest-qt-2.3.0-r2.ebuild
index 068bf8e7c463..faf751eebf8a 100644
--- a/dev-python/pytest-qt/pytest-qt-2.3.0-r2.ebuild
+++ b/dev-python/pytest-qt/pytest-qt-2.3.0-r2.ebuild
@@ -12,7 +12,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="doc"
RDEPEND="
diff --git a/dev-python/pytest-qt/pytest-qt-2.3.0.ebuild b/dev-python/pytest-qt/pytest-qt-2.3.0.ebuild
deleted file mode 100644
index 846360f394a6..000000000000
--- a/dev-python/pytest-qt/pytest-qt-2.3.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_5 )
-inherit distutils-r1
-
-DESCRIPTION="pytest plugin for PyQt4 or PyQt5 applications"
-HOMEPAGE="https://pypi.org/project/pytest-qt/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-RDEPEND="
- >=dev-python/pytest-2.7.0[${PYTHON_USEDEP}]
- || (
- dev-python/PyQt4
- dev-python/PyQt5
- )
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-py3doc-enhanced-theme[${PYTHON_USEDEP}]
- )
-"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-# Test make assumptions about Qt environment
-RESTRICT="test"
-
-python_compile_all() {
- use doc && sphinx-build -b html docs _build/html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( _build/html/. )
- distutils-r1_python_install_all
-}