summaryrefslogtreecommitdiff
path: root/dev-python/pytest-qt/pytest-qt-3.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/pytest-qt/pytest-qt-3.3.0.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/pytest-qt/pytest-qt-3.3.0.ebuild')
-rw-r--r--dev-python/pytest-qt/pytest-qt-3.3.0.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/pytest-qt/pytest-qt-3.3.0.ebuild b/dev-python/pytest-qt/pytest-qt-3.3.0.ebuild
index 1a43c9248d65..55715700f9e8 100644
--- a/dev-python/pytest-qt/pytest-qt-3.3.0.ebuild
+++ b/dev-python/pytest-qt/pytest-qt-3.3.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
@@ -19,7 +19,13 @@ KEYWORDS="~amd64 ~x86"
DEPEND="dev-python/QtPy[gui,testlib,${PYTHON_USEDEP}]"
-PATCHES=( "${FILESDIR}/${P}-skip-show-window-test.patch" )
+# Patch 1 skips a test that does not work inside the emerge environment:
+# pytestqt.exceptions.TimeoutError: widget <PyQt5.QtWidgets.QWidget object at 0x7f57d8527af8> not activated in 1000 ms.
+# Patch 2 fixes upstream bug 314
+PATCHES=(
+ "${FILESDIR}/${P}-skip-show-window-test.patch"
+ "${FILESDIR}/${P}-fix-file-match-test.patch"
+)
distutils_enable_tests pytest
distutils_enable_sphinx docs dev-python/sphinx_rtd_theme