summaryrefslogtreecommitdiff
path: root/dev-python/pytest-qt/pytest-qt-3.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/pytest-qt/pytest-qt-3.3.0.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/pytest-qt/pytest-qt-3.3.0.ebuild')
-rw-r--r--dev-python/pytest-qt/pytest-qt-3.3.0.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/pytest-qt/pytest-qt-3.3.0.ebuild b/dev-python/pytest-qt/pytest-qt-3.3.0.ebuild
deleted file mode 100644
index 8e4e3f6611c2..000000000000
--- a/dev-python/pytest-qt/pytest-qt-3.3.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="pytest plugin for PyQt5 and PySide2 applications"
-HOMEPAGE="
- https://pypi.org/project/pytest-qt/
- https://github.com/pytest-dev/pytest-qt/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="dev-python/QtPy[gui,testlib,widgets(+),${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/PyQt5[gui,testlib,widgets,${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/pyside2[gui,testlib,widgets,${PYTHON_USEDEP}]
- ' python3_{7..9} )
- )
-"
-
-# Patch 1 skips a test that does not work inside the emerge environment:
-# pytestqt.exceptions.TimeoutError: widget <PyQt5.QtWidgets.QWidget object at 0x7f57d8527af8> not activated in 1000 ms.
-# Patch 2 fixes upstream bug 314
-PATCHES=(
- "${FILESDIR}/${P}-skip-show-window-test.patch"
- "${FILESDIR}/${P}-fix-file-match-test.patch"
-)
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
-
-python_prepare_all() {
- # This is not going to work since we want to test both implementations
- # and therefore pull in both and explicitly set PYTEST_QT_API
- sed -i -e 's:test_qt_api_ini_config_with_envvar:_&:' \
- -e 's:test_qt_api_ini_config:_&:' \
- tests/test_basics.py || die
-
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- virtx python_foreach_impl python_test
-}
-
-python_test() {
- distutils_install_for_testing
- PYTEST_QT_API="pyqt5" epytest
- if [[ "${EPYTHON}" == "python3.10" ]]; then
- return
- else
- PYTEST_QT_API="pyside2" epytest
- fi
-}