summaryrefslogtreecommitdiff
path: root/dev-python/pytest-pylint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/pytest-pylint
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/pytest-pylint')
-rw-r--r--dev-python/pytest-pylint/Manifest6
-rw-r--r--dev-python/pytest-pylint/metadata.xml2
-rw-r--r--dev-python/pytest-pylint/pytest-pylint-0.14.1.ebuild39
-rw-r--r--dev-python/pytest-pylint/pytest-pylint-0.17.0.ebuild40
4 files changed, 45 insertions, 42 deletions
diff --git a/dev-python/pytest-pylint/Manifest b/dev-python/pytest-pylint/Manifest
index 6955a52f65da..e1ff013dbce8 100644
--- a/dev-python/pytest-pylint/Manifest
+++ b/dev-python/pytest-pylint/Manifest
@@ -1,3 +1,3 @@
-DIST pytest-pylint-0.14.1.tar.gz 8144 BLAKE2B d78892e3e606ec588b48a252db447e1cc76e27e45606670da3a3acddf040485004a7af84474732b044fdbf80ad760c07fda5e35030b9b2c9e5ce89f4809529c2 SHA512 697cd40e8e4c3722e382c7fd2dbebcb1728675e35b60396628576ec09735595af56431a2c080f29a2f35f304d912c80e4afdf0f8bd21a3adeae3156b9e58c751
-EBUILD pytest-pylint-0.14.1.ebuild 1066 BLAKE2B 198a3d9651fb4f5d38aeaed5c4944244dc682882b89261cb23c97e64b68160ea1614f368586263e043fd424a3aee979034a8eee6b07e6f93a86ae7cc91838ead SHA512 08eaddb1c87546439de9bb85a9d747874b2b865914810089593cd07434f957d58f8174d5c5ce782834ce6e2434d7227ca7fd4ea6b143e21ceaf84e85c1f5a3f8
-MISC metadata.xml 306 BLAKE2B ef6d4e4bd779cdbec5e76617003defe8581c1c2b04b6098efce973a9b2eb154da51bdc27e8c202df1dc6c4a6393471b917dd47f2e95e75487dcba7a8fa725ae4 SHA512 726037520d25c038ab6a35c14edce11561e281fcfbb6a505bf3ead4d474cb10606b715f95c6df95e22e97f20f840c1694bde08984f9211bc46b5d0afb46f1c4e
+DIST pytest-pylint-0.17.0.tar.gz 11660 BLAKE2B b536dcaaf0ac652dcbe66018fa22e120782496de58f74003c523eb003ff0556f9b738e528a85724a1e589e18bb0024d99fbeb581b7f5b36ec349ad07da8d26d0 SHA512 a23937ec191ef14829530ac6bf31b882bc250f312e2ba6e3b8cc1187c888511e4b67ffaf5bce176556a621fbf80239b30c43c635898d458bb8d819e92a9f8142
+EBUILD pytest-pylint-0.17.0.ebuild 1118 BLAKE2B 3222712c426effdcc025e90607a9460acff6914d2aa82553778e6ad66224f06def4c05f9af4ec1c591aabbf95763a1e69e6dcc63f01dc6bb759311f504e65649 SHA512 fd2ec87a31d06cca9df1478caffa4a2daee0ede685ea0c5834d761f1e94c18769cfdc794db630befc82bf2716cdf33c6d41bcae9f5ea02a1eab0e0809f8d0f73
+MISC metadata.xml 428 BLAKE2B 5986f5476c70157e31680be898d8b45cf38d1fa303aeac5d9336796e0b5941de9170d781ecddf308174b9b4aff51ec9fefa5c6620ee49f9121005aa86229a740 SHA512 65370aeb2b8c39941a34035ae9c44f5e19fdf4c533e50f9641870b2496773a5f782460f4518f79a2e45489c871f3e18d05a2d36fe8610fd1ea87e616f39a9a19
diff --git a/dev-python/pytest-pylint/metadata.xml b/dev-python/pytest-pylint/metadata.xml
index 0e3bc0471a62..4f79f21e49ec 100644
--- a/dev-python/pytest-pylint/metadata.xml
+++ b/dev-python/pytest-pylint/metadata.xml
@@ -6,5 +6,7 @@
</maintainer>
<upstream>
<remote-id type="github">carsongee/pytest-pylint</remote-id>
+ <remote-id type="pypi">pytest-pylint</remote-id>
+ <bugs-to>https://github.com/carsongee/pytest-pylint/issues</bugs-to>
</upstream>
</pkgmetadata>
diff --git a/dev-python/pytest-pylint/pytest-pylint-0.14.1.ebuild b/dev-python/pytest-pylint/pytest-pylint-0.14.1.ebuild
deleted file mode 100644
index 85605fa7eb8b..000000000000
--- a/dev-python/pytest-pylint/pytest-pylint-0.14.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-inherit distutils-r1
-
-DESCRIPTION="pytest plugin to check source code with pylint"
-HOMEPAGE="https://github.com/carsongee/pytest-pylint"
-SRC_URI="https://github.com/carsongee/pytest-pylint/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pylint[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-pep8[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- # pytest grabs the options from tox.ini automatically
- # but setup.py does not declare pytest-pep8 as a dep,
- # so it's missing from env created by distutils_install_for_testing
- sed -i -e 's:--pep8::' tox.ini || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- distutils_install_for_testing
- py.test -v || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/pytest-pylint/pytest-pylint-0.17.0.ebuild b/dev-python/pytest-pylint/pytest-pylint-0.17.0.ebuild
new file mode 100644
index 000000000000..2ecd55e96177
--- /dev/null
+++ b/dev-python/pytest-pylint/pytest-pylint-0.17.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to check source code with pylint"
+HOMEPAGE="https://github.com/carsongee/pytest-pylint"
+# Tests should be included in PyPI tarballs by the next release:
+# https://github.com/carsongee/pytest-pylint/commit/4e7f06701ca06697a22a029db9857fa2fdf7c033
+SRC_URI="https://github.com/carsongee/pytest-pylint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pylint-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.7.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Disable flake8 and pep8 options
+ sed -i -e '/^addopts =/d' tox.ini || die
+ # Remove pytest-runner requirement
+ sed -i -e "s/'pytest-runner'//" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Required to load the pytest-pylint plugin
+ distutils_install_for_testing
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}