summaryrefslogtreecommitdiff
path: root/dev-python/pytest-pylint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/pytest-pylint
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/pytest-pylint')
-rw-r--r--dev-python/pytest-pylint/Manifest2
-rw-r--r--dev-python/pytest-pylint/pytest-pylint-0.17.0.ebuild40
2 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/pytest-pylint/Manifest b/dev-python/pytest-pylint/Manifest
index 11c10a4cc414..dccf21883796 100644
--- a/dev-python/pytest-pylint/Manifest
+++ b/dev-python/pytest-pylint/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-pylint-0.17.0.tar.gz 11660 BLAKE2B b536dcaaf0ac652dcbe66018fa22e120782496de58f74003c523eb003ff0556f9b738e528a85724a1e589e18bb0024d99fbeb581b7f5b36ec349ad07da8d26d0 SHA512 a23937ec191ef14829530ac6bf31b882bc250f312e2ba6e3b8cc1187c888511e4b67ffaf5bce176556a621fbf80239b30c43c635898d458bb8d819e92a9f8142
DIST pytest-pylint-0.18.0.tar.gz 12448 BLAKE2B 9d0cecb08fc87d7e2aade47af3f2677431776a425726c281e9abc5fdeebb84f38ab4a97e405ed407b1cd241eb97a8cd90e878af61f818b46cab5f9fba5ca3d5f SHA512 a0716104d288774d4c3ab596f30a33cf439df5031647912574c31eefc3a84e69e82fc362f77e73b437c7566a596d2ff8bf51a332626a7fa7468cea3b916e9ad9
-EBUILD pytest-pylint-0.17.0.ebuild 1118 BLAKE2B 2afc692f96d558d956eee04d70b2a516babfff606a858117efeb3f5efd0631823f3a99706dd10441d682101ff994f732f8dee84a2367390245f28cc85bd25086 SHA512 9047a6777d0ea48b040b4249531b2e5254dd535202a3bba2745614286f4d2d628e9a99aaf950515374cb2d4dfee17595a3b61c0da109e63479b4fb580fbb5626
EBUILD pytest-pylint-0.18.0.ebuild 828 BLAKE2B a21b8e989827bbe4447a82c70e956cd19860b44f5e14329812d801a40fd1626fa7a530c21bb5132b1e0ef355713fa8cfd5999b4c02170850f736440b8a369387 SHA512 f2a4961a484bcedbdd5794c46bdd78185f1872d5686a9c6cdea9d5fd6296bfa4608178aaf781af014a9fbf76c6da704762989aa7c71a3ccc90131e5e78aedf4b
MISC metadata.xml 475 BLAKE2B de0705d225f09df06d9a42516c17f4f4bfdaef5900f905a8631f6abbbc8f97d4745b2a6bce73763a827ca87ac7d5ed03e334546daa613a30b8749dd4de76009d SHA512 7b6e5a04ff56019fd87cfeb3a24c5f2a0d660d635c0163a4cdf8febee6279149417a624332c081008b923474b16ac0a4f41f31a8060e7170e9a38c21f247f142
diff --git a/dev-python/pytest-pylint/pytest-pylint-0.17.0.ebuild b/dev-python/pytest-pylint/pytest-pylint-0.17.0.ebuild
deleted file mode 100644
index d08f66d86c87..000000000000
--- a/dev-python/pytest-pylint/pytest-pylint-0.17.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..8} )
-
-inherit distutils-r1
-
-DESCRIPTION="pytest plugin to check source code with pylint"
-HOMEPAGE="https://github.com/carsongee/pytest-pylint"
-# Tests should be included in PyPI tarballs by the next release:
-# https://github.com/carsongee/pytest-pylint/commit/4e7f06701ca06697a22a029db9857fa2fdf7c033
-SRC_URI="https://github.com/carsongee/pytest-pylint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/pylint-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
- >=dev-python/toml-0.7.1[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Disable flake8 and pep8 options
- sed -i -e '/^addopts =/d' tox.ini || die
- # Remove pytest-runner requirement
- sed -i -e "s/'pytest-runner'//" setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Required to load the pytest-pylint plugin
- distutils_install_for_testing
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}