summaryrefslogtreecommitdiff
path: root/dev-python/pytest-plus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/pytest-plus
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/pytest-plus')
-rw-r--r--dev-python/pytest-plus/Manifest3
-rw-r--r--dev-python/pytest-plus/metadata.xml13
-rw-r--r--dev-python/pytest-plus/pytest-plus-0.2.ebuild23
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-plus/Manifest b/dev-python/pytest-plus/Manifest
new file mode 100644
index 000000000000..c4006a0ceda0
--- /dev/null
+++ b/dev-python/pytest-plus/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-plus-0.2.tar.gz 8210 BLAKE2B b8a28e72cfb4e10daa021528de9b5df2e9eb0bc4e911557c7c14a0825284787e94992132c0b74881867a41b55a67785c60b9b87a1594ad33fb57ebac8de391a6 SHA512 e16a03433cb6eb30b6881bec99482bc65cb7d1fa3d0db855befe666c0645d4b5ec02debde9dec4322ed0a0b77d3ac3f1cabda0cf98f375ffd68dc29fb55f5139
+EBUILD pytest-plus-0.2.ebuild 615 BLAKE2B d21357de62f51b1adfbcb572bfc67332679e7d26896bbf03e44c5d9e1fb09ff29fa799b4ea4a892f546202512900ebebee5f2cd0683536569d66c5cc917eed0f SHA512 cd1f394a7ee7e7523af9363ee9b5f459ac41a6d10eab8bb5a5014f90ccff804e5ec9b82b58a8442d34d19f1a13ecd0a7a2b4fa871952dac7c757780f1e3bccbe
+MISC metadata.xml 405 BLAKE2B 4c4cf92ac0ce7254649db7061d80244044d6cf0584063700c98b5535b9bee4b389e12f2196c9f8d3edf5351e17d329ddfbbf3cc08c452cb8af26ee0aad0f1995 SHA512 2ec67d3aea49b836424afc3898702cafec058bcb3362988495f00ee1427e061707c5dafbd3584c49e5ab2f32cc5c6e225ef5edeeab83f10ee2129371664010bd
diff --git a/dev-python/pytest-plus/metadata.xml b/dev-python/pytest-plus/metadata.xml
new file mode 100644
index 000000000000..11989dba8342
--- /dev/null
+++ b/dev-python/pytest-plus/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">pytest-dev/pytest-plus</remote-id>
+ <remote-id type="pypi">pytest-plus</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-plus/pytest-plus-0.2.ebuild b/dev-python/pytest-plus/pytest-plus-0.2.ebuild
new file mode 100644
index 000000000000..3bd50d2af4a9
--- /dev/null
+++ b/dev-python/pytest-plus/pytest-plus-0.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="PyTest Plus Plugin - extends pytest functionality"
+HOMEPAGE="https://github.com/pytest-dev/pytest-plus"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest