summaryrefslogtreecommitdiff
path: root/dev-python/pytest-param-files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/pytest-param-files
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/pytest-param-files')
-rw-r--r--dev-python/pytest-param-files/Manifest5
-rw-r--r--dev-python/pytest-param-files/metadata.xml13
-rw-r--r--dev-python/pytest-param-files/pytest-param-files-0.3.3.ebuild25
-rw-r--r--dev-python/pytest-param-files/pytest-param-files-0.3.4.ebuild24
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/pytest-param-files/Manifest b/dev-python/pytest-param-files/Manifest
new file mode 100644
index 000000000000..a32ff326333c
--- /dev/null
+++ b/dev-python/pytest-param-files/Manifest
@@ -0,0 +1,5 @@
+DIST pytest-param-files-0.3.3.gh.tar.gz 6858 BLAKE2B 6614b00dcfab63241daee0951bea442afb885942c4ab1ce0b2f6b4c3fe1e0a6048955d79cb1bd703f31ffedaede19b36f40caded98e0c8dc014b64e847110a00 SHA512 d52d0aa44088879ee5cd55f8af56ed649a1a82420bed357be043fdcc0df4899002cae36d95c6864126eaaa97877a21aedabb00dd12a8730d6aee3bcaecdcee62
+DIST pytest-param-files-0.3.4.gh.tar.gz 6882 BLAKE2B e2e96bd2cf7b8676f92eeb7821ef76f1f82bb066210170ed4d04a16a7fb3ce346bcd63688ef9d46118c03fd74812fd821fff0414565befb8c558d03d15af2945 SHA512 2df6fe798aab743fdbf892b88ee1d09c554119429167e85bccb87e4ae9d487f8ab5a66c4157827500e8a5d2930277c7490348f6c38f23243e421d5449bde2df5
+EBUILD pytest-param-files-0.3.3.ebuild 599 BLAKE2B 0c30ebb44922864f818696df631ac0379c0af775848d07406ce09d43fe164e52c65bc9f1f82d0d7e38aecdb3521d1bb2844cc8edd2328b5b7c3737228b5da268 SHA512 40aca0bf68eaac7a60eac8eded075fe1c11313828c3f57e868935aa888f133f4f67017ada365389d21a6a89731c5ef1f37cd4d4803d6da148dc37ced8fc7c016
+EBUILD pytest-param-files-0.3.4.ebuild 589 BLAKE2B d1bd8803f9e824ebf1c6de7e656ee5f34a696ccb82a2c608bcc38a9502e2629af600d14c8798db35cc39547ced90bc7d89195987e8eaa3c2bff7141f6ac71645 SHA512 c5fc87e98561e51a26dc3d0aa01de2ab17fba584f1e568fa3e9f0d166d5f7cf93ae6a4c3e641f341da406d3f44c4019861d27769f817f28ad934607b83b5d032
+MISC metadata.xml 417 BLAKE2B 94bde89ae7cf0181aba1215f8a406889a4473736c37cc325c57635f590f72369402e54f8e54f0b528c9757229b4fdf8608b292a15cc6fa83a997aeb53a64b4ea SHA512 f5b341a0619f750edc6e3f22fc3cfb0c5204d2ce19a756df0f5b282f97fe133f8891105c48b532711bba826ef4cca935eeed4fbb0703da5213cbc3074b7229c2
diff --git a/dev-python/pytest-param-files/metadata.xml b/dev-python/pytest-param-files/metadata.xml
new file mode 100644
index 000000000000..a59f07232de3
--- /dev/null
+++ b/dev-python/pytest-param-files/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pytest_param_files</remote-id>
+ <remote-id type="github">chrisjsewell/pytest-param-files</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-param-files/pytest-param-files-0.3.3.ebuild b/dev-python/pytest-param-files/pytest-param-files-0.3.3.ebuild
new file mode 100644
index 000000000000..1a00f6b23a3a
--- /dev/null
+++ b/dev-python/pytest-param-files/pytest-param-files-0.3.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=flit
+inherit distutils-r1
+
+DESCRIPTION="Pytest parametrize decorators from external files."
+HOMEPAGE="https://pypi.org/project/pytest_param_files/
+ https://github.com/chrisjsewell/pytest-param-files"
+SRC_URI="
+ https://github.com/chrisjsewell/pytest-param-files/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
diff --git a/dev-python/pytest-param-files/pytest-param-files-0.3.4.ebuild b/dev-python/pytest-param-files/pytest-param-files-0.3.4.ebuild
new file mode 100644
index 000000000000..4bd1d3f4866b
--- /dev/null
+++ b/dev-python/pytest-param-files/pytest-param-files-0.3.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=flit
+inherit distutils-r1
+
+DESCRIPTION="Pytest parametrize decorators from external files."
+HOMEPAGE="https://pypi.org/project/pytest_param_files/
+ https://github.com/chrisjsewell/pytest-param-files"
+SRC_URI="
+ https://github.com/chrisjsewell/pytest-param-files/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest