summaryrefslogtreecommitdiff
path: root/dev-python/pytest-ordering
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-python/pytest-ordering
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-python/pytest-ordering')
-rw-r--r--dev-python/pytest-ordering/Manifest3
-rw-r--r--dev-python/pytest-ordering/files/pytest-ordering-0.6-fix-pytest-6.patch21
-rw-r--r--dev-python/pytest-ordering/pytest-ordering-0.6.ebuild8
3 files changed, 29 insertions, 3 deletions
diff --git a/dev-python/pytest-ordering/Manifest b/dev-python/pytest-ordering/Manifest
index 175d2b8af504..109a50a8f60b 100644
--- a/dev-python/pytest-ordering/Manifest
+++ b/dev-python/pytest-ordering/Manifest
@@ -1,3 +1,4 @@
+AUX pytest-ordering-0.6-fix-pytest-6.patch 920 BLAKE2B 2b964bd2cef5f947bc53554abb8c7f0432f3a8ca632b0f52dd304836a79a4e4050edc0e6350f92f517f43a8fec077a58ec407ec90ee1489501ceb7b6971fa76b SHA512 7164f9982668dbdeb016e39937101bf879b6b0267e05f854b34a50637505ed762f6fbc931428e346591e7a1b1ce1da0a929f19222931db5b284bdcbdd2fc0ef7
DIST pytest-ordering-0.6.tar.gz 11046 BLAKE2B 468ae5f04029b96ed3058b7f429aec0aaf96092453b229c3de5eab174702af2c1a9fe83171c68d282c4a144b3dd736daf9ed87b9e139a7bd175114f504049ebc SHA512 fd3aec83914f64d1295e1a1bf3fdc580c6824a749a1da8cebae275fef940d6ed6e5dcafad321d94f504a153e13e298b6544dc3c2db716a6b25d3148c2365fe15
-EBUILD pytest-ordering-0.6.ebuild 870 BLAKE2B b44ea3f2392b3eb1989dff5b0df1764991d2598d9d28e8352fca4866b9e3d72ca03cd2833af384ee5aedbec59bddb32f8345438a66965bd345b59d952269fd3c SHA512 188df2e6b31de1ceca21ebf9d4c2babf50b38781140bde768657eac40e666ea0f75b7169d731956b7e72c630e990ae446f09f20fea6b5ec8d6067a4fefcc2930
+EBUILD pytest-ordering-0.6.ebuild 919 BLAKE2B 3fbd5f620665c87a3cddc45a3a8505b7278a3fffe84d885b97a08ff2d1c54c78cc9d2292c45d73bb9fe946080e6bdfcc734d6579d708a8f42322c637cf0e9b62 SHA512 d5d7f5cf5ba4c9860f2587f95ce98026d0909ca9c409ba790a89df817e284ef11ecf5037895385dfce00e017b6ff4c93ce0b6e3d727b872d34444c723492c57f
MISC metadata.xml 423 BLAKE2B b33ec2a8e4852bb8d9865369719cc4c38398950279b84ba6feb2a7869b42824310ce9a664cc6cf7b3a1febee4d86048158923a396fce9ee1e99051daf34d6e69 SHA512 dc144919d84e8933f9ce70faa6482ff0334d28fb7e6a5b2feba53d29d3b2002cef05a6012e1e2764a8364da39b2914b2e8ac7101611828c41809372fda94a12e
diff --git a/dev-python/pytest-ordering/files/pytest-ordering-0.6-fix-pytest-6.patch b/dev-python/pytest-ordering/files/pytest-ordering-0.6-fix-pytest-6.patch
new file mode 100644
index 000000000000..3a3ea15f4b8e
--- /dev/null
+++ b/dev-python/pytest-ordering/files/pytest-ordering-0.6-fix-pytest-6.patch
@@ -0,0 +1,21 @@
+From 9bfb05700386254afabb38f762e0ea860b567209 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
+Date: Tue, 26 Jan 2021 20:42:14 +0100
+Subject: [PATCH] Don't use accidental pytest API, fix tests for pytest 6.2+
+
+https://github.com/ftobia/pytest-ordering/pull/76
+
+--- a/tests/test_ordering.py
++++ b/tests/test_ordering.py
+@@ -12,9 +12,9 @@ def item_names_for(testdir):
+ def _item_names_for(tests_content):
+ # some strange code to extract sorted items
+ items = testdir.getitems(tests_content)
+- hook = testdir.config.hook
++ hook = items[0].config.hook
+ hook.pytest_collection_modifyitems(session=items[0].session,
+- config=testdir.config, items=items)
++ config=items[0].config, items=items)
+ return [item.name for item in items]
+
+ return _item_names_for
diff --git a/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild b/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
index 0bd6f7293be1..25ef67eebc14 100644
--- a/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
+++ b/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -18,7 +18,11 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 sparc x86"
-RDEPEND="<dev-python/pytest-6[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-pytest-6.patch"
+)
distutils_enable_tests --install pytest
distutils_enable_sphinx docs/source