summaryrefslogtreecommitdiff
path: root/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/pytest-ordering/pytest-ordering-0.6.ebuild')
-rw-r--r--dev-python/pytest-ordering/pytest-ordering-0.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild b/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
new file mode 100644
index 000000000000..a6fe80e2943f
--- /dev/null
+++ b/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to run your tests in a specific order"
+HOMEPAGE="
+ https://github.com/ftobia/pytest-ordering
+ https://pypi.org/project/pytest-ordering
+"
+SRC_URI="https://github.com/ftobia/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="test? ( dev-python/pytest-ordering[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source
+
+python_prepare_all() {
+ # TypeError: `args` parameter expected to be a list or tuple of strings, got: '--markers' (type: <class 'str'>)
+ sed -i -e 's:test_run_marker_registered:_&:' \
+ tests/test_ordering.py || die
+
+ distutils-r1_python_prepare_all
+}