summaryrefslogtreecommitdiff
path: root/dev-python/pytest-order
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-03 08:13:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-03 08:13:59 +0100
commit2df2e0ebc717aa53904c920c1a361423dfc3a5f7 (patch)
treed81b257b3923100dc55a999dd12b2198a6d35b99 /dev-python/pytest-order
parent75abd8d3830449158bdd27f9c4701bcbadc55080 (diff)
gentoo auto-resync : 03:04:2024 - 08:13:58
Diffstat (limited to 'dev-python/pytest-order')
-rw-r--r--dev-python/pytest-order/Manifest2
-rw-r--r--dev-python/pytest-order/pytest-order-1.2.1.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pytest-order/Manifest b/dev-python/pytest-order/Manifest
index 6988493fe7b2..b52d19538dfa 100644
--- a/dev-python/pytest-order/Manifest
+++ b/dev-python/pytest-order/Manifest
@@ -1,3 +1,5 @@
DIST pytest-order-1.2.0.tar.gz 44307 BLAKE2B 82611b713c9ae064c41e966d503c649c130d5a1df520594f513e9ab3d1cf6890fba65afa860822aedcee1a95617d3cd9010f5189d158cd76b2a4b9d25dd7d916 SHA512 f615dd57546e90c614af35fd79e7e579d48a5e709af3324f476d347e191606b81698bde619a2d0c7181e6f3b1a3c41121c1b06b5de87e66ac2caa77b5ea11ad9
+DIST pytest-order-1.2.1.tar.gz 44726 BLAKE2B b0365a6c7d420e5997ca67fc3de3d46a02a085f024ba2777c480f4c9da7e90ac3dd3b533d67e43934429f3a1ace1725171c56ad59eeb598c06bbe4dbbc5f71e0 SHA512 2ea89f05e6dcf82a6df596feeb1e25b634e48c4c6219b5320b662e88b5ee2473062f3bf1d38696dac2e045fdf51a118b7907c4a06a90e6e256b4d21bd156be18
EBUILD pytest-order-1.2.0.ebuild 1160 BLAKE2B db1722901d104da9fab84b9080781d7c6f5ab1012fe2133aff29da216c077c9341b127b0efbc5e59e77f86f0ebcc15dc74c923d366a7c69ef6dd3a0678f1acb8 SHA512 0ce6c3547ee05801fbe987fe1f0c968caa479b99577eeb2f929ea521aa1b4fca0accc016ae76912b3b56051c9e57441837a1944a2b8b2ce8fa3d2228e8742936
+EBUILD pytest-order-1.2.1.ebuild 1160 BLAKE2B db1722901d104da9fab84b9080781d7c6f5ab1012fe2133aff29da216c077c9341b127b0efbc5e59e77f86f0ebcc15dc74c923d366a7c69ef6dd3a0678f1acb8 SHA512 0ce6c3547ee05801fbe987fe1f0c968caa479b99577eeb2f929ea521aa1b4fca0accc016ae76912b3b56051c9e57441837a1944a2b8b2ce8fa3d2228e8742936
MISC metadata.xml 421 BLAKE2B 6b76a2376d1a001a247a842a493da9b341c9c355f0319072adaa55b20fa93397ed49f6ea6e965cd19bf3681e2a45bd9b34a9dadfc6bd59417fc88f3e04d19f4d SHA512 057e59a4e3e4d47f0b777531b6900a60516b2c26baf2a260b4fe34693c4568f77be45da02eb5b78dae27891845b0e6a7fcf4f9a0cdb59ee45e8ed54537795e8a
diff --git a/dev-python/pytest-order/pytest-order-1.2.1.ebuild b/dev-python/pytest-order/pytest-order-1.2.1.ebuild
new file mode 100644
index 000000000000..f861ccc1aacd
--- /dev/null
+++ b/dev-python/pytest-order/pytest-order-1.2.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin to run your tests in a specific order"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-order/
+ https://pypi.org/project/pytest-order/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-6.4.2[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # these require pytest-dependency
+ tests/test_dependency.py::test_order_dependencies_no_auto_mark
+ tests/test_dependency.py::test_order_dependencies_auto_mark
+ tests/test_order_group_scope_dep.py::test_class_group_scope_module_scope
+ tests/test_order_group_scope_named_dep.py::test_class_group_scope_module_scope
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_order.plugin,xdist.plugin,pytest_mock
+ epytest
+}