summaryrefslogtreecommitdiff
path: root/dev-python/pytest-mpl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pytest-mpl
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pytest-mpl')
-rw-r--r--dev-python/pytest-mpl/Manifest3
-rw-r--r--dev-python/pytest-mpl/metadata.xml15
-rw-r--r--dev-python/pytest-mpl/pytest-mpl-0.8.ebuild31
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pytest-mpl/Manifest b/dev-python/pytest-mpl/Manifest
new file mode 100644
index 000000000000..ac0ca1e7fd95
--- /dev/null
+++ b/dev-python/pytest-mpl/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-mpl-0.8.tar.gz 194633 BLAKE2B b21b26ef95ca3d83d429348a639365d19eacce298ecb2cd5964a8be47970d077bff40692ee992a1cd412572623f1cc2a8a502c5b59f526b4f9830d89973f23cb SHA512 4f5f1316d0f545383b9125281b91d9077b52bfa7d91b4eb2f64c6f9642b1abe86c52c9b88171a521d806e579ab9279f49d1405b3f4fcae58a9e75ec5518bacca
+EBUILD pytest-mpl-0.8.ebuild 784 BLAKE2B cab42269abcdaae2236a962074e34e7c267c2ed2d78be8188e9febfd03b7cf9a4f91cdee764259abded9b2de2427961ca0f12828a556b0cacb68d3794caf5370 SHA512 0e9ff99199f5b743adedfd76891cb5cccf311bd59f9b415e3c4ee9772071bb29f56d796d108a20d5a1313d0a4cc8f91a7a68b5d854dc7395fd8d344745a5ff17
+MISC metadata.xml 521 BLAKE2B 152f49e9eb75c777ad953a6090feb9e3415e19400a6c1de71c99529fbdc48f6073f189af8292ccd61ccad2be9d91849eb6091d315b20e3d01408bf614052d514 SHA512 5b8552f0e0a0c96577e14c8ec98bbdc0f1577d7d25cc41a2fc9d173b0fb45b4c74a9bd66e6357f665c0947c237feceb2d276ef3058046054598804acc6d4430b
diff --git a/dev-python/pytest-mpl/metadata.xml b/dev-python/pytest-mpl/metadata.xml
new file mode 100644
index 000000000000..53dc3963e0d4
--- /dev/null
+++ b/dev-python/pytest-mpl/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">pytest-mpl</remote-id>
+ <remote-id type="github">astrofrog/pytest-mpl</remote-id>
+ </upstream>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is a plugin to faciliate image comparison for Matplotlib figures in pytest.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pytest-mpl/pytest-mpl-0.8.ebuild b/dev-python/pytest-mpl/pytest-mpl-0.8.ebuild
new file mode 100644
index 000000000000..91a3f43ff90d
--- /dev/null
+++ b/dev-python/pytest-mpl/pytest-mpl-0.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1 virtualx
+
+DOCS=( README.rst CHANGES.md )
+
+DESCRIPTION="pytest plugin to faciliate image comparison for matplotlib figures"
+HOMEPAGE="https://github.com/astrofrog/pytest-mpl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ echo "backend : Agg" > "${T}"/matplotlibrc || die
+ MPLCONFIGDIR="${T}" virtx py.test -v || die
+}