summaryrefslogtreecommitdiff
path: root/dev-python/pytest-mpl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-04 00:00:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-04 00:00:19 +0100
commit7f3fecbb5b871825fe9632f46659869cab6a3769 (patch)
treedd2be4fe7ee3475ca4ad093698f0f8fd1e0965dc /dev-python/pytest-mpl
parenta98588cfddf3d6e88a5f17d7f399b695163c7a85 (diff)
gentoo auto-resync : 04:05:2024 - 00:00:19
Diffstat (limited to 'dev-python/pytest-mpl')
-rw-r--r--dev-python/pytest-mpl/Manifest2
-rw-r--r--dev-python/pytest-mpl/pytest-mpl-0.17.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytest-mpl/Manifest b/dev-python/pytest-mpl/Manifest
index 061fa0959a45..7f3b5ce6c5d9 100644
--- a/dev-python/pytest-mpl/Manifest
+++ b/dev-python/pytest-mpl/Manifest
@@ -1,3 +1,5 @@
DIST pytest-mpl-0.16.1.tar.gz 663585 BLAKE2B aad171260a10417aab15e7e55115c2fe02aa33dcf8336634281e1a1dad4d1c5ff08293fd9a67be025ec6cbb18c42bc9eb7ccb86275c0fcc7f4bf33a035fc0927 SHA512 64c1689f1698f9223082bc5c6817a1d4f9b413cb193894c23b1e0302254a6358cb3e354ac92ec47677acf460a41d05b2b527c834fd0fbbde04c070b0af8f46e1
+DIST pytest-mpl-0.17.0.tar.gz 885613 BLAKE2B d1a6d4551052eeeb7ecbf9722c782796aa74215a3241d1c037fca98972777dd35d7616ec8ef2bd4f00b6428f5dea516243244b61f56ec38d72a4805a75c91a50 SHA512 968397b1d75482729ad73f4844970c3c335c009e689f4163bd5a028c84627455a7d20563e62c6940b27c62229e5744496bec36c2440d402c0aee0a7853550f9b
EBUILD pytest-mpl-0.16.1.ebuild 798 BLAKE2B 5ec6c49d7e8beab008bf083e44145bf24562b8c4cd97afa097ebbd0209623ad4e2155976854baadea6927dc214da86b5a4ee277ce4f6ed2cf4af1761bb5af036 SHA512 da140b6eca2f8f5658ddb06752e6b99025d8acb3300d46b9a5f3048a5fbf7c4f9382701516699a2a356a4a7b1c35f63dd7b4f26abe08cdc51c93df974122a21a
+EBUILD pytest-mpl-0.17.0.ebuild 970 BLAKE2B 96b753ad8ccf30023db407907db37c78d04b0761bd0689d355ed8fa5ead0059a13839dda348420654c63b394241217ec9db68b4e71e205b64d273cf745f20603 SHA512 a4706765e881a8918c50d5c1d2610c5dfcebbb05e8bd4fc7ce8d9c6ea7b9bf6f3c2eb324320c6d26c67d745948748597e575f102bb22e0b22c35ee0f19468e4e
MISC metadata.xml 399 BLAKE2B b2dd8993ce1e55737997ac3e6c0d26edecad7721c319073b8bc12117b1387dd3b6a1049837b5f97d97f5539d1253bf888f00caca6f0bbb46a73292ee6bd08f0f SHA512 5e3c8b4c47771acf6fe345f3e1d1ae59e66a2bd028ff57969cd3a93aef971b7103a7b0d847f1e53af54075603f9868d5c09895f4ea3a1d93009b07449496d317
diff --git a/dev-python/pytest-mpl/pytest-mpl-0.17.0.ebuild b/dev-python/pytest-mpl/pytest-mpl-0.17.0.ebuild
new file mode 100644
index 000000000000..f2e06c02aa48
--- /dev/null
+++ b/dev-python/pytest-mpl/pytest-mpl-0.17.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Facilitate image comparison for Matplotlib figures"
+HOMEPAGE="
+ https://pypi.org/project/pytest-mpl/
+ https://github.com/matplotlib/pytest-mpl
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+EPYTEST_DESELECT=(
+ tests/test_baseline_path.py::test_config
+ tests/test_pytest_mpl.py::test_formats
+ tests/test_results_always.py::test_config
+ tests/test_use_full_test_name.py::test_config
+ tests/subtests/test_subtest.py::test_default
+ tests/subtests/test_subtest.py::test_html_images_only
+)
+
+distutils_enable_tests pytest