summaryrefslogtreecommitdiff
path: root/dev-python/pytest-mpl/pytest-mpl-0.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pytest-mpl/pytest-mpl-0.8.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pytest-mpl/pytest-mpl-0.8.ebuild')
-rw-r--r--dev-python/pytest-mpl/pytest-mpl-0.8.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pytest-mpl/pytest-mpl-0.8.ebuild b/dev-python/pytest-mpl/pytest-mpl-0.8.ebuild
new file mode 100644
index 000000000000..866279f7b950
--- /dev/null
+++ b/dev-python/pytest-mpl/pytest-mpl-0.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1 virtualx
+
+DOCS=( README.rst CHANGES.md )
+
+DESCRIPTION="pytest plugin to faciliate image comparison for matplotlib figures"
+HOMEPAGE="https://github.com/astrofrog/pytest-mpl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ echo "backend : Agg" > "${T}"/matplotlibrc || die
+ MPLCONFIGDIR="${T}" virtx py.test -v || die
+}