summaryrefslogtreecommitdiff
path: root/dev-python/pytest-mock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-22 17:18:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-22 17:18:34 +0000
commitfd87b7c771378b2116981e3924bee5805148e118 (patch)
tree91ed28393c7b534787d3c073e269fe598d0fd535 /dev-python/pytest-mock
parent77b74be093bdf4a0ed4121acc3f8e229103cf004 (diff)
gentoo auto-resync : 22:11:2023 - 17:18:34
Diffstat (limited to 'dev-python/pytest-mock')
-rw-r--r--dev-python/pytest-mock/Manifest4
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.11.1.ebuild54
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.12.0.ebuild2
3 files changed, 2 insertions, 58 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index e3ecb592d876..4aca20be3776 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-mock-3.11.1.tar.gz 31251 BLAKE2B 26655487947d614483f082f17c9f3a9fc2688c016d07c6d4c4e34c369f87f3d914cf82d966a655e1eee501088d27d711f1b65f0c777678254dcfffa5c8c7585f SHA512 f52147498657d35f4616ea788b500a68ffcf1c2c066047fb973308b54e11bd7fe5a3961115bab99ae6858000ebb68b35cc489e81221a0bd26afae8426092ff6b
DIST pytest-mock-3.12.0.tar.gz 32139 BLAKE2B 4bc2289579686b8ca9e840440b21b7299817e803f108726692cda6f1a138564462b04b9ae6a3038a5e36ec4d665bb7c8f54c26d231d6b17188b8d830d553b20d SHA512 6da429e646a4e3a825f699969dbc87033136918bd9aa111ff334fac324e5ac89ef6516e82ffeeb20cb6a857fbbe904d8ee985acefba2d2b7bd0ffe4b9227ad82
-EBUILD pytest-mock-3.11.1.ebuild 1235 BLAKE2B 86631d6db534c3f1387249cab08f14907b3bde25b80c12569d016cb56f3154db7b214f5bd95f88f4af15d82cb29c9ae36cb6c2d57ac4bfdbb8e36a0bb2c93496 SHA512 e467081ebfc9673a5dcf9ccfd9f1a96a8b5df6f82a7e8499c980376c5e2b781f8398877068dc97f00da2387185756bf2ab1aaeea3a979545abb512c5001fb263
-EBUILD pytest-mock-3.12.0.ebuild 1243 BLAKE2B fb567b31625e3346e23791c20630ca1d95c7deb795d30575c68e990bef2af8a82f3cc953b447efad681a5e7f1a0c9197478ae31eab76da0b50fe156cfd66e197 SHA512 ffcb06e96ccc9bc7056ea9d051f3e0e821ac30f2516a696d7514286cb67ca464c4cef946af0136bcc66557bb3e0201bb38f00ab60ed16ce42f690db9a63769b6
+EBUILD pytest-mock-3.12.0.ebuild 1235 BLAKE2B 86631d6db534c3f1387249cab08f14907b3bde25b80c12569d016cb56f3154db7b214f5bd95f88f4af15d82cb29c9ae36cb6c2d57ac4bfdbb8e36a0bb2c93496 SHA512 e467081ebfc9673a5dcf9ccfd9f1a96a8b5df6f82a7e8499c980376c5e2b781f8398877068dc97f00da2387185756bf2ab1aaeea3a979545abb512c5001fb263
MISC metadata.xml 379 BLAKE2B 47a45606cecad3ecc9b902d9ec690c33a89728ce93038433f11ab8c3369089ef12e86c793ab06dedeef7a816dc973ae8ea2a6b717b13085c7912d69bcd68db65 SHA512 b5e43e5e0a1cfba50868ca542b00d40084aeb38f764f203ed112a9359e966e94d34a99bbb072b98f9401a0383d3fbf834b8b87572e073592263f18d73f09db2e
diff --git a/dev-python/pytest-mock/pytest-mock-3.11.1.ebuild b/dev-python/pytest-mock/pytest-mock-3.11.1.ebuild
deleted file mode 100644
index 21e83bfc0670..000000000000
--- a/dev-python/pytest-mock/pytest-mock-3.11.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_TESTED=( python3_{10..12} pypy3 )
-PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-mock/
- https://pypi.org/project/pytest-mock/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/pytest-6[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- $(python_gen_cond_dep '
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- ' "${PYTHON_TESTED[@]}")
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- if ! has "${EPYTHON/./_}" "${PYTHON_TESTED[@]}"; then
- einfo "Skipping tests on ${EPYTHON}"
- return
- fi
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_mock,pytest_asyncio.plugin
- local EPYTEST_DESELECT=()
-
- if has_version dev-python/mock; then
- EPYTEST_DESELECT+=(
- tests/test_pytest_mock.py::test_standalone_mock
- )
- fi
-
- epytest --assert=plain
-}
diff --git a/dev-python/pytest-mock/pytest-mock-3.12.0.ebuild b/dev-python/pytest-mock/pytest-mock-3.12.0.ebuild
index fffc7a4e5350..21e83bfc0670 100644
--- a/dev-python/pytest-mock/pytest-mock-3.12.0.ebuild
+++ b/dev-python/pytest-mock/pytest-mock-3.12.0.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
RDEPEND="
>=dev-python/pytest-6[${PYTHON_USEDEP}]